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1.1 Summary
This document defines software requirements, installation, configuration, running select applications, and integration 
demonstrations for using NetIQ AppManager with the AlarmPoint software suite. These integration notes are intended for 
administrators and other technical readers. 

1.1.1 Overview
The following steps must be completed for a successful integration between NetIQ AppManager and the AlarmPoint 
System: 

• Installation – Describes the steps required to install applications the integration uses.

• Configuration – Illustrates the setup for the AlarmPoint System and NetIQ AppServer components.

• Software Component Integration – Demonstrates a two-way notification when a monitored hard disk reaches a 
predefined limit.

1.2 System Requirements
The following products must be installed and operating correctly prior to integration:

• NetIQ AppManager Suite 6.0 or higher.

• AlarmPoint 3.0.0

• AlarmPoint Java Client 2.3.4

1.3 Conventions & Terminology
This section describes how styles are used in the document, and provides a list of definitions.

1.3.1 Conventions
Some instructions appear in the following format: MENU > OPTION; for example, File > Open means click the File 
menu, and then click the Open menu option.

Words in bold typically reference text that appears on the screen.

Words in monospace font represent the following:

• text that must be typed into the computer

• directory and file names

1.3.2 Terminology
With respect to NetIQ AppManager, the following definitions apply:

1. Introduction

Term Meaning

Alarm Item of interest detected by NetIQ AppManager
Summary   |  1
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With respect to the AlarmPoint System, the following definitions apply:

Event One or more items associated with an alarm

UUID Unique identifier associated with an alarm

Term Meaning

AlarmPoint Admin Administrative tool to control AlarmPoint Agent

AlarmPoint Agent Communication layer between third-party applications (e.g., a Management 
System) and AlarmPoint

AlarmPoint Bridge AlarmPoint Agent uses this to interact with the Management System. For users 
wanting to develop their own integration, consult the AlarmPoint Bridge JavaDoc 
included with your integration package.

AlarmPoint Client The Management System uses this to communicate with the AlarmPoint Agent

AlarmPoint Application Server 
Node

The core AlarmPoint application, consisting of various components that process 
events and perform notifications.

AlarmPoint Java Client Umbrella term for the AlarmPoint Admin, AlarmPoint Agent, AlarmPoint Bridge, 
and the AlarmPoint Client (both Java and native versions)

AlarmPoint Notification Server 
Node

Delivers notifications to a User in a variety of ways (pager, phone, e-mail, etc.)

AlarmPoint System Umbrella term for all AlarmPoint software components

AlarmPoint Web User Interface Browser-accessible interface for controlling AlarmPoint components and 
information.

Management System A synonym for NetIQ AppManager

Alert Item of interest that typically generates a notification for a User or Group

Device Medium through which a User is contacted (e-mail, phone, pager, etc.)

Situation What has happened with the device

Target Person or group who should be notified of the NetIQ AppManager Alarm

User Manual The AlarmPoint Server or AlarmPoint Enterprise User Manual (deployment 
dependent)

Term Meaning
nventions & Terminology



2.1 AlarmPoint System

2.1.1 AlarmPoint (Notification) Server
Consult the user manual for installation instructions.

2.1.2 AlarmPoint Enterprise
Consult the user manual for installation instructions.

2.1.3 AlarmPoint Java Client
The AlarmPoint Java Client allows AppManager to call the AlarmPoint Agent in the event of a notification; it must be 
installed on the same computer as the AppManager. Consult the AlarmPoint user manual for installation instructions.

2.2 NetIQ AppManager
Consult the NetIQ user manual for installation instructions.

2. Installation
AlarmPoint System   |  3
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1. From the console menu, select KS > Check In Knowledge Script. 

2. In the File Selection box, select the Action_AlarmPoint.qml file that you just copied to the hard disk.

3. Click Open. When complete you will receive a message that the Knowledge Script has been successfully checked in.
tIQ AppManager



4. To verify, click on the Action tab from the right windowpane; the new AlarmPoint script is listed.  
NetIQ AppManager   |  5
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3.1 AlarmPoint
Configuring AlarmPoint requires five steps: importing the AlarmPoint script package, installing the Voice files, defining an 
Event Domain, setting up a User with a two-way pager, and installing the NetIQ AppManager Knowledge Script..

3.1.1 Importing the AlarmPoint script package
This step requires the AlarmPoint Developer IDE. For installation instrustions, refer to the AlarmPoint Developer’s Guide & 
Scripting Reference.

To import the AlarmPoint Script Package:

1. Launch the IDE, and configure the database connection (refer to the AlarmPoint Developer IDE Help or the AlarmPoint 
Developer’s Guide & Scripting Reference for details)

2. Click Workspace > Import.

Note: Ensure that your workspace is empty before continuing.

3. Select the NetIQ-AppManager-1.00.aps file extracted from the integration zip file into the following folder:

•     AP3-NetIQ-AppManager/components/alarmpoint/scripts

4. In the File dialog box, click OK, and then click OK again.

5. Right-click the NetIQ AppManager (Business) folder.

6. In the Validation dialog box, select Validate, and then click Close.

7. Right-click the NetIQ AppManager (Business) folder, and then click Check In.

8. In the Check In dialog box, click Create.

9. In the Script Package dialog box, click Remove, and then click Close.

10. Close the IDE.

3.1.2 Install Voice Files
These files must be installed into an AlarmPoint deployment running a Voice Device Engine. For more information, refer to 
the AlarmPoint Installation and Administration Guide.

To install the voice files:

1. Copy all of the files in the AP3-NetIQ-AppManager\components\alarmpoint\vox\english folder from the 
extracted integration zip file to the following node installs folder:
node\phone-engine\Datastore\Recordings\<language>\Phrases

Note: This integration provides only English voice files.

3.1.3 Define an Event Domain
The AlarmPoint webserver must be running to perform this portion of the integration. 

3. Configuration
AlarmPoint   |  7
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To define an Event Domain:

1. Login to AlarmPoint as a Company Administrator, and click the Developer tab.

2. In the Developer menu on the left side of the screen, click Event Domains.

3. On the Event Domains page, click Add New.

4. Enter the following information into the form:

• Name: appmanager

• Description: NetIQ AppManager Integration

• Script Package: NetIQ AppManager

5. Click Save.

6. Log out of AlarmPoint.

Note: It is strongly recommended that you use the Event Domain Name specified above. For the integration to be 
successful, the Event Domain name must match the Client ID of the AlarmPoint Java Client.

3.1.4 Setting up a two-way Device
By default this integration is set up to use a default demonstration User named “user 9999”. Follow the steps below to ensure 
that this User exists and has a virtual 2-way pager Device:

Note: To perform this portion of the integration, the AlarmPoint webserver must be running.

To set up a two-way Device:

1. Login to AlarmPoint as a Company Administrator, and click the Users tab.

2. On the Find Users page, click S. 

3. In the list of returned Users, click Smith, Bob.

4. On the Details for Bob Smith page, in the Common Tasks pane, click User Devices.

5. Verify that a virtual pager device exists.

6. Click Reorder, and set the virtual pager to be the first Device in the list.

7. Click Save.

8. Log out of AlarmPoint.

Note: If this user is missing, create a user with a User ID of 9999 and add a virtual pager Device for the User. For more 
information and instructions on how to perform these tasks, refer to the AlarmPoint User Guide.

3.1.5 Knowledge Script
In the AP3-NetIQ-AppManager/components/netiq-appmanager folder is a custom Knowledge Script for 
AppManager. 

1. To Install the Knowledge Script:

• Copy the file called Action_AlarmPoint.qml from the integration file (AP3-NetIQ-AppManager/
components/netiq-appmanager) to the hard disk of the AppManager system. 

• Open the Net IQ AppManager Operator Console. 
armPoint



The following is a capture of the Operator Console:

3.2 AlarmPoint Java Client
The installed version of the NetIQ AppManager integration that comes with APJC 2.2.4 must be updated to the version 
provided in the integration zip.

1. Shut down the APAgent

2. Replace the installed file appmanager.xml, located in <install-path>/APAgent/etc/integrations, with the 
one from the integration archive folder:

• AP3-NetIQ-AppManager/components/alarmpoint-java-client

3. Make sure the APJC /etc/APAgent.xml configurtaion file has the following line 
• <alarmpoint-agent-client id="appmanager" filename="integrations/appmanager.xml" />

4. Within the etc/integrations/appmanager.xml file, there are two path statements that need to be modified based 
on where AppManager is installed. Change the paths accordingly.

• Command lines:

    execute( "c:\\program files\\netiq\\appmanager\\bin\\netiqcmd" +
      " ackevent.vbs /SERVER=" + APDT_servername + " /DATABASE=" +
      APDT_databasename + " /USER=" + APDT_loginid + " /EVENTID=" +
      APDT_incident_id + " /PASSWORD=" + APDT_loginidpassword );
  }
  else if( APDT_request_text.equalsIgnoreCase( "APPMANAGER_CLEAR" ) )
  {
    execute( "c:\\program files\\netiq\\appmanager\\bin\\netiqcmd" +
      " closeevent.vbs /SERVER=" + APDT_servername + " /DATABASE=" +
      APDT_databasename + " /USER=" + APDT_loginid + " /EVENTID=" +
AlarmPoint Java Client   |  9
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      APDT_incident_id + " /PASSWORD=" + APDT_loginidpassword );

Note: After changing the appmanager.xml file, you must restart the Java Client.

5. Restart the APAgent

Below is an example of the data mapping section of the APAgent.xml file.
<mapped-input method="add" subclass="action">
   <parameter index="1" type="string">person_or_group_id</parameter>
   <parameter index="2" type="string">situation</parameter>
   <parameter index="3" type="string">device</parameter>
   <parameter index="4" type="string">incident_id</parameter>
   <parameter index="5" type="string">event_msg</parameter>
   <parameter index="6" type="string">server_name</parameter>
   <parameter index="7" type="string">database_name</parameter>
   <parameter index="8" type="string">login_id</parameter>
   <parameter index="9" type="string">login_id_password</parameter>
   <parameter index="constant" type="string"
      value="appmanager">action_script_set</parameter>
</mapped-input>

3.3 NetIQ AppManager

3.3.1 Creating an AlarmPoint Account in AppManager
To create new users in AppManager the Security Manager program must be installed on the system. The Security Manager 
program can be installed when you install the NetIQ AppManager console component. To use the Security Manager, you 
must have System Administrator (sa) privileges or be a member of the admin group for the AppManager repository 
database.

By logging on to the Security Manager with the System Administrator (sa) account, you can perform all Security Manager 
tasks, which includes being able to create new SQL Server users from within the Security Manager. If you log on with an 
admin account (but not sa), you cannot create new SQL Server users but you can perform all other Security Manager tasks.

3.3.1.1 Create a New User:
1. From the NetIQ AppManager Operator Console menu, select Extensions > Security Manager.
etIQ AppManager
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2. In the NetIQ AppManager Security Manager window menu, select Security > User Setup.
etIQ AppManager



3. From the AppManager User Setup window, click on the New SQL User button.

4. In the New SQL User dialog box, enter the new SQL user name and SQL login password.

5. Click OK to close the box.

6. When the New SQL User dialog box closes you will be back at the AppManager User Setup dialog box. The name of 
the user just created is listed in the left window under SQL users. 

7. Click once on the new user to highlight it. 
NetIQ AppManager   |  13
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8. Click Add. A progress bar will appear and it will add the new user to the AppManager users list on the right side of the 
window. 

9. Click on the Close button at the bottom of the AppManager User Setup dialog box.
etIQ AppManager



10. Verify the new user has been created by expanding the AppManager Users tree on the left side of the NetIQ 
AppManager Security Manager dialogue. 

11. Exit the NetIQ AppManager Security Manager window by selecting Security > Exit.

3.3.2 To Log On as the New User:
1. Exit the NetIQ AppManager Operator Console dialogue box. 

2. Restart NetIQ AppManager. 

3. At the NetIQ AppManager Operator Console Logon dialogue box, enter the name and password of the new user.

3.4 Software Component Validation
The recommended practice is to run the applications in the following order:

• AlarmPoint 3 Node with Device Engine(s)

• AlarmPoint Java Client

Consult the AlarmPoint user manual for details on starting these applications.

3.4.1 AlarmPoint Java Client
This section shows how to verify that the AlarmPoint Java Client can communicate with its server (AlarmPoint Server or 
AlarmPoint Enterprise, depending on your deployment). For both Windows and Unix, the last line on the console will 
Software Component Validation   |  15
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indicate a successful connection. If the connection cannot not be established, consult the user manual for more information 
and troubleshooting tips.

1. Provided that the AlarmPoint Java Client was not installed as a Service, after installation of NetIQ AppManager is 
complete, open a new command prompt (Start > Run > cmd > OK). If you do not use a new command prompt, the 
PATH environment variable might not include the AppManager bin directory. 

2. Within the command prompt window, type:
cd C:\APAgent
APAgent

This starts the AlarmPoint Agent. The output should look similar to the following:

If critical problems arise (file errors, communication difficulties, insufficient memory, etc.), the Health Monitor may be used 
to send an e-mail. However, the Health Monitor is optional.

Note: In a production environment, the AlarmPoint Java Client should be installed as a Windows Service. This helps 
ensure that if the system is restarted, the AlarmPoint Agent will run automatically.
oftware Component Validation



4.1 Trigger a Notification
1. Open the Net IQ AppManager Operator Console. 

2. Click on the Action tab from the right window pane.

4. Software Component Integration
Trigger a Notification   |  17
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3. Double click on the AlarmPoint script to open it. A properties dialogue bow will open as shown.

These fields are used for various parameters of the integration. Any of them can be preset to a different value by modifying 
the Action_AlarmPoint knowledge script. The values can be changed at any time simply by clicking in the value column of 
the property and typing a new value.

Property Description Purpose

Action Script Set to run on 
AlarmPoint

 This is the Action script that will be used by AlarmPoint to deliver the message. 

AlarmPoint Person or Group 
ID to notify

This is the AlarmPoint Person ID or the Group ID to be notified.

AppManager Repository 
Server

This is the machine name for the system that AppManager is running on. By default, if 
left blank, the local machine name will be used.

AppManager Database Name This is the name for the repository database. By default, if left blank, "QDB" will be 
used.

AlarmPoint Login ID This defines the AppManager user id to use when acknowledging events.
rigger a Notification



4. Click OK to close the Properties dialogue box.

5. Click on the appropriate tab in the right window pane for your operating system.

6. In the left pane, open the File System - Logical Disk sub-tree.

7. Click on LogicalDiskSpace and drag it to the logical disk to monitor until a green circle appears. This will start a job 
monitoring the percentage of the disk used. 

AlarmPoint Login ID 
Password

This parameter works in conjunction with the above parameter.

Override the Event Message 
with this text

The standard AppManager Event Message will be used for email and alpha paging. If 
you would like to send a different message, type it here.

Override the EventID with this 
EventID

This parameter is used mainly for testing. If the default EventID is overridden, the 
acknowledgement of the event will not work correctly.

Property Description Purpose
Trigger a Notification   |  19
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8. A Properties dialogue box will appear. Click on the Values tab.

9. By default, the Threshold - Used Space is set to 95%; adjust this value to 5%. Assuming the disk is at least 5% filled, 
this will trigger a notification.

10. Click on the Actions tab.
rigger a Notification



11. Pull down the drop down box under Action and choose Action_AlamPoint.

12. Click OK. The AlarmPoint script will now run, triggering a notification.  

4.2 View Results
The event will be displayed in the bottom window pane of the AppManager Operator Console. Notice that the status is 
Open.

A notification will have been sent to the AlarmPoint (Notification) Server and the virtual pager will be displayed. The virtual 
pager can be used to respond to the notification and the results will be updated in the AppManager Operator Console 
window.
View Results   |  21
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None at this time.
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6. Change Notes

Document Version Date Description of Change

1.1 14 APR 2005 • Document converted to new technical standard

• Updated for NetIQ AppManager 6.0 and higher

• Example Notification explained in more detail.
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You can access the AlarmPoint Systems Web Site at http://www.alarmpoint.com. From this site you can obtain information 
about the Company, the Products, Support and other helpful information. You may also access the Customer Support Site 
from the main web page. In this protected site you will find current product releases, helpful hints, patches, release notes, a 
helpful product knowledge base, trouble ticket submission areas and other helpful tools provided by AlarmPoint Systems, 
Inc. 

7. Contact Us

AlarmPoint Systems, Inc.
7011 Koll Center Parkway, 
Suite 160
Pleasanton, CA 94566

Phone: 925-226-0300 
Fax: 925-226-0310

E-mail: support@alarmpoint.com
Website: 
http://www.alarmpoint.com 

NetIQ Corporation
3553 N. First St.
San Jose, CA 95134

Phone: 1-408-856-3000
Fax: 1-408-273-0578
Sales: 1-888-323-6768
Email: info@netiq.com

Website: http://www.netiq.com/
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©AlarmPoint Systems 2005. Rights to reproduce this document only by written permission of AlarmPoint Systems.

8. Copyright
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