
AlarmPoint for
BMC CONTROL-M

Copyright AlarmPoint Systems, Inc. 1994-2010

Confidential & Proprietary

Validation Date

February 2, 2010

Version 1.1





Contents
1. Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1
SUMMARY . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Benefits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
ARCHITECTURE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
SYSTEM REQUIREMENTS. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
CONVENTIONS & TERMINOLOGY . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Terminology  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2. Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  4
ALARMPOINT SYSTEM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

AlarmPoint Java Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
AlarmPoint  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

BMC CONTROL-M. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
INTEGRATION  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

Installing the integration components . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

3. Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  6
SECURITY  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
ALARMPOINT  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

Importing the AlarmPoint script package  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
Install Voice Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
Define an Event Domain . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Setting up a two-way Device . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

ALARMPOINT JAVA CLIENT . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Basic Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Copy and Configure the Integration XML Configuration File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Edit APAgent.xml . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
CONTROL-M/EM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

BMC CONTROL-M SYSTEM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Communication Administration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Example Batch Job Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

SOFTWARE COMPONENT VALIDATION . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

4. Software Component Integration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17
TRIGGER A NOTIFICATION  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
INITIATE A NOTIFICATION REQUEST. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
VIEW REQUEST RESULTS  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

5. Frequently Asked Questions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  20
WHAT DOES “JAVA.IO.IOEXCEPTION: NOT ENOUGH SPACE” MEAN? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
WHY ARE THE LOGS SENT BY E-MAIL MISSING INFORMATION? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
WHAT DO I DO WHEN I HAVE AN INCOMPATIBLE VERSION ERROR?. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
HOW DO I CHANGE A JOB SKELETON’S DEFAULT CONTROL-M DEFINITION? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
HOW DO I CHANGE THE VERSION OF A CONTROL-M DEFINITION? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

6. Troubleshooting. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21
Verify that AlarmPoint is installed and running. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Verify that AlarmPoint can send notifications. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
  i



Contents
Verify that each AlarmPoint Java Client is pointing to and communicating with AlarmPoint. . . . . . . . . . . . . . . . . 21
Confirm the location of integration files.  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
CONTROL-M/EM, CONTROL-M/Agent, and CONTROL-M/Server must all be installed and running. . . . . . . . 22
Check the CONTROL-M/EM configuration.  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

7. Contact Us . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23
8. Copyright  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24
  ii



IntroductionAlarmPoint for BMC CONTROL-M
1. Introduction
Welcome to the AlarmPoint for BMC CONTROL-M integration. This document defines software requirements and 
describes installation, configuration, running select applications, and integration demonstrations for using BMC 
CONTROL-M with AlarmPoint. These integration notes are intended for administrators and other technical readers. 

1.1 Summary
AlarmPoint is an interactive alerting application, designed to capture and enrich important events, to route those events to 
the right person on any communication device, and to give that person the ability to solve, escalate, or enlist others to resolve 
the events remotely.

AlarmPoint allows you to take critical business information and contact the right people via voice phone, SMS, two-way 
pagers, instant message, and email.

Through integration modules, the AlarmPoint System can become the voice and interface of an automation engine or 
intelligent application (the Management System, such as BMC CONTROL-M). When CONTROL-M detects an alert that 
requires attention, AlarmPoint places phone calls, sends pages, messages, or emails to the appropriate personnel, vendors or 
customers. 

The AlarmPoint System is also persistent, escalating through multiple devices and personnel until someone accepts 
responsibility or resolves the alert. Once contacted, the AlarmPoint System gives the notified person instant two-way 
communication with BMC CONTROL-M. Responses are executed immediately on BMC CONTROL-M, enabling remote 
control over the alert.

You will need to modify the configuration to suit your particular business requirements and adjust it to suit your expected 
loads. Consider your expected volume of injected events and your server capacity when designing your own integration with 
AlarmPoint. It is recommended that you set up a demonstration system as described in this documentation to become 
familiar with the integration before you deploy it into a pre-production or production environment. 

1.1.1 Benefits 
With the AlarmPoint integration, the support staff assigned to the alert can be notified directly via telephone, email, pager, or 
other device. Information about the alert will be presented to the notification recipients and decisions can be made in real-
time. 

Once a response is selected on the recipient’s remote device, AlarmPoint updates the alert in real-time. The benefit is that 
this process is immediate – significantly faster than the time required for support staff to handle the alert. In addition, the 
ability for recipients to update alerts remotely allows for events to be handled quickly and without the originator’s direct 
involvement. During the process, every notification, response, and action is logged in AlarmPoint. 

The AlarmPoint product also features a self-service web user interface to allow accurate assignment of responsible personnel 
for each job. 

1.2 Architecture
This example integration describes how to integrate an AlarmPoint System with a CONTROL-M/EM deployment. The key 
components include:

• AlarmPoint Client binary (APClient.bin)

• AlarmPoint Agent Response Action Script per CONTROL-M/Server

• CONTROL-M/Server CTMPSM command line API

The following diagram provides a high-level overview of the major components for this integration:
Summary   |  1
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The following steps (corresponding to the numbers in the diagram above) outline at a high level how an Alert triggers a 
notification, and how the response to that notification is resolved: 

1. CONTROL-M/EM generates an Alert, which is passed via the AlarmPoint Client binary to AlarmPoint Client.

2. AlarmPoint Client submits the Alert details to AlarmPoint Agent.

3. AlarmPoint Agent sends a message to AlarmPoint, which causes the actual notification to be sent.

4. The person responds to the notification with a request to perform an action relating to the job that triggered the Alert.

5. The request is routed back to the AlarmPoint Agent on the CONTROL-M/Server that detected the job fault.

6. The AlarmPoint Agent executes the request action in a Response Action Script using CTMPSM.

1.3 System Requirements
The following products must be installed and operating correctly prior to integration:

• BMC CONTROL-M/EM 6.1.03 or later

• BMC CONTROL-M/Server 6.1.03 or later

• BMC CONTROL-M/Agent 6.1.03 or later

• AlarmPoint 4.0 (patch 007 or later)

• AlarmPoint Java Client 4.0 (patch 001 or later)

Consult the respective user manuals for a detailed list of hardware and supporting software requirements.

1.4 Conventions & Terminology
This section describes how styles are used in the document, and provides a list of definitions.
System Requirements   |  2
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1.4.1 Conventions
Some instructions appear in the following format: MENU > OPTION; for example, File > Open means click the File menu, 
and then click the Open menu option.

Words in bold typically reference text that appears on the screen.

Words in monospace font represent the following:

• text that must be typed into the computer

• directory and file names

Except where explicitly stated, the directory paths in this document are listed in Unix format. Windows users must substitute 
the given paths with the Windows equivalents. For example, on Unix systems, the AlarmPoint Java Client is typically 
installed in /home/controlm/alarmpointsystems/APAgent. On Windows systems, it is typically installed in the 
default directory, C:\APAgent.

1.4.2 Terminology
With respect to the AlarmPoint System, the following definitions apply:

Term Meaning

AlarmPoint Admin Administrative tool to control AlarmPoint Agent

AlarmPoint Agent Communication layer between third-party applications (e.g., BMC Patrol 
Enterprise Manager) and AlarmPoint

AlarmPoint Bridge AlarmPoint Agent uses this to interact with BMC CONTROL-M

AlarmPoint Client The Management System uses this to communicate with the AlarmPoint Agent

AlarmPoint Application Server 
Node

The core AlarmPoint application, consisting of various components that process 
events and perform notifications.

AlarmPoint Java Client Umbrella term for the AlarmPoint Admin, AlarmPoint Agent, AlarmPoint Bridge, 
and the AlarmPoint Client (both Java and native versions)

AlarmPoint Notification Server 
Node

Delivers notifications to a person in a variety of ways (pager, phone, e-mail, etc.)

AlarmPoint System Umbrella term for all AlarmPoint software components

Management System A generic term for BMC CONTROL-M

Alert Item of interest that typically generates a notification for a User or Group

Device Medium through which a User is contacted (e-mail, phone, pager, etc.)

User Guide The AlarmPoint user guides and documentation 
Conventions & Terminology   |  3
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2. Installation
This section describes how to install the following software components:

• AlarmPoint System

• BMC CONTROL-M

• AlarmPoint – CONTROL-M Integration

2.1 AlarmPoint System
This integration requires the following AlarmPoint applications to be installed:

• AlarmPoint

• AlarmPoint Java Client

Note: It is recommended that the AlarmPoint Java Client be the only AlarmPoint application installed on the 
CONTROL-M/Server.

2.1.1 AlarmPoint Java Client
The AlarmPoint Java Client is the communications bridge between the CONTROL-M applications and the rest of the 
AlarmPoint System. It allows CONTROL-M to inform the AlarmPoint System when a problem occurs. It must be installed 
on the CONTROL-M/EM machine and on each CONTROL-M/Server computer. 

Under Unix, the AlarmPoint Java Client must be installed in the controlm directory so that it can find and execute the 
ctmpsm command. To accomplish this under Windows, add the CONTROL-M directory (C:\Program Files\BMC 
Software\CONTROL-M Agent\Default\EXE\) to the PATH environment variable.

Note: Under Unix, you must run the installer using the CONTROL-M/Server account, even if CONTROL-M/EM and 
CONTROL-M/Server are on the same machine.

For instructions on installing the AlarmPoint Java Client, refer to the AlarmPoint Java Client Guide.

2.1.2 AlarmPoint
For installation instructions, refer to the AlarmPoint Installation and Administration Guide.

2.2 BMC CONTROL-M
This integration requires the following BMC CONTROL-M applications to be installed:

• CONTROL-M/Agent

• CONTROL-M/Server

• CONTROL-M/EM

• CONTROL-M/EM GUI (Desktop Clients)

Consult the CONTROL-M Installation Guide for instructions on how to install and configure these applications.
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2.3 Integration
After the CONTROL-M and AlarmPoint systems have been installed, integration components must be placed on each 
system. The integration zip archive contains updates for AlarmPoint and the AlarmPoint Java Client, and files for the BMC 
CONTROL-M Server. 

Extract the integration archive AP40-BMC-Control-M.zip.

The significant files and directories (in bold) of the archive are as follows:

|-- components
| |-- alarmpoint
| | |-- scripts
| | | ‘-- BMC-Control-M-1.1.aps
| | ‘-- vox
| |   ‘-- english (contains english phrases)
| ‘-- alarmpoint-java-client
|   |-- lib
|   | ‘-- com.invoqsystems.fieldmap.jar
|   |-- BMC-CTRLM_cohost.xml
|   |-- BMC-CTRLM_enterprise.xml
|   |-- BMC-CTRLM_server.xml
|   ‘-- job-target.map
|-- documentation
| ‘-- AP40-BMC-CONTROL-M.pdf
‘-- release-notes.txt

2.3.1 Installing the integration components
To install the integration components, you need to update a JAR file in the Java Client for the fieldmap.

To update the JAR:

1. In the extracted integration archive, locate the following file:

/components/alarmpoint-java-client/lib/com.invoqsystems.fieldmap.jar 

2. Copy the file to the following location within the AlarmPoint Java Client directory:

APAgent/jre/lib/ext 
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3. Configuration

3.1 Security
The AlarmPoint System and CONTROL-M/Server must have a user relationship established. This is done by mapping 
AlarmPoint users and groups to corresponding CONTROL-M/Server users. New integration installations do not have this 
mapping configured; user mappings must be done manually.

The possible job actions (ctmkilljob, ctmpsm, etc.) for each mapped user must be defined, and will be validated against 
the assigned CONTROL-M/Server user whenever an action is requested from the AlarmPoint System.

Use the ctmsec command to adjust the abilities per CONTROL-M/Server user. Consult the appropriate CONTROL-M 
documentation for details.

3.2 AlarmPoint
Configuring AlarmPoint requires four steps: importing the AlarmPoint script package, installing the Voice files, defining an 
Event Domain and setting up a User with a two-way pager.

3.2.1 Importing the AlarmPoint script package
This step requires the AlarmPoint Developer IDE. For installation instrustions, refer to the AlarmPoint Developer’s Guide & 
Scripting Reference.

To import the AlarmPoint Script Package:

1. Launch the IDE, and configure the database connection (refer to the AlarmPoint Developer IDE Help or the 
AlarmPoint Developer’s Guide & Scripting Reference for details)

2. Click Workspace > Import.

Note: Ensure that your workspace is empty before continuing.

3. Select the BMC-Control-M-1.1.aps file extracted from the integration zip file into the following folder:

•     AP3-BMC-CONTROLM\components\alarmpoint\scripts\

4. In the File dialog box, click OK, and then click OK again.

5. Right-click the BMC Control-M (Business) folder.

6. In the Validation dialog box, select Validate, and then click Close.

7. Right-click the BMC Control-M (Business) folder, and then click Check In.

8. In the Check In dialog box, click Create.

9. In the Script Package dialog box, click Remove, and then click Close.

10. Close the IDE.

3.2.2 Install Voice Files
These files must be installed into an AlarmPoint deployment running a Voice Device Engine. For more information, refer to 
the AlarmPoint Installation and Administration Guide.
Security   |  6
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To install the voice files:

1. Copy all of the files in the AP3-BMC-CONTROLM\components\alarmpoint\vox\english folder from the 
extracted integration zip file to the following node installs folder:

node\phone-engine\Datastore\domains\common\Recordings\<language>\Phrases

Note: This integration provides only English voice files.

3.2.3 Define an Event Domain
The AlarmPoint Webserver must be running to perform this portion of the integration. 

To define an Event Domain:

1. Login to AlarmPoint as a Company Administrator, and click the Developer tab.

2. In the Developer menu on the left side of the screen, click Event Domains.

3. On the Event Domains page, click Add New.

4. Enter the following information into the form:

• Name: ctrlm

• Description: BMC Control-M Integration

• Script Package: BMC Control-M

5. Click Save.

6. Log out of AlarmPoint.

Note: It is strongly recommended that you use the Event Domain Name specified above. For the integration to be 
successful, the Event Domain name must match the Client ID of the AlarmPoint Java Client.

3.2.4 Setting up a two-way Device
You can use any User or Group as a target for notifications, such as the default demonstration User named “Bob Smith”. 
Follow the steps below to ensure that this User exists and has a virtual two-way pager Device:

Note: To perform this portion of the integration, the AlarmPoint webserver must be running.

To set up a two-way Device:

1. Login to AlarmPoint as a Company Administrator, and click the Users tab.

2. On the Find Users page, click S. 

3. In the list of returned Users, click Smith, Bob.

4. On the Details for Bob Smith page, in the Common Tasks pane, click User Devices.

5. Verify that a virtual pager device exists.

6. Click Reorder, and set the virtual pager to be the first Device in the list.

7. Click Save.
AlarmPoint   |  7
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8. Log out of AlarmPoint.

Note: If this user is missing, create a User with a virtual pager Device and use them as a target for notifications. For 
more information and instructions on how to perform these tasks, refer to the AlarmPoint User Guide.

3.3 AlarmPoint Java Client
Once the AlarmPoint Java Client is installed, several steps must be taken to configure it for the integration:

3.3.1 Basic Configuration
Use the steps specific to your operating system to configure the AlarmPoint Java Client.

Unix

1. Determine the subdirectory to use for integration files (subsequently referred to as the integration directory).

2. Create a folder called alarmpoint in the CONTROL-M/EM user’s directory; i.e.:

/home/emuser/alarmpoint

3. Copy the APClient executable (APCLient.bin) from the AlarmPoint Agent’s installation directory into the 
integration directory. 

• This allows the CONTROL-M/EM user to run the binary to submit messages into the AlarmPoint Agent. Ensure 
that the CONTROL-M/EM user can run APClient.bin within the integration directory. You may have to use a 
combination of chmod 755 and chown.

4. Copy the AP3-BMC-Control-M/components/alarmpoint-java-client/job-target.map file from the 
extracted integration archive to the AlarmPoint Agent’s installation directory.

Windows

1. Copy the AP3-BMC-Control-M\components\alarmpoint-java-client\job-target.map file from the 
extracted integration archive to the AlarmPoint Agent’s installation directory.

3.3.2 Copy and Configure the Integration XML Configuration File
1. Decide which XML configuration file is appropriate for your CONTROL-M deployment:

• CONTROL-M/Server: BMC-CTRLM_server.xml

• CONTROL-M/EM: BMC-CTRLM_enterprise.xml

• CONTROL-M/EM with CONTROL-M/Server: BMC-CTRLM_cohost.xml

2. Copy only the appropriate XML configuration file from the AP3-BMC-Control-M\components\alarmpoint-
java-client\ folder in the extracted integration archive to the AlarmPoint Agent’s integrations directory:

Unix: 

/opt/alarmpointsystems/APAgent/etc/integrations

Windows:

C:\APAgent\etc\integrations

3. If you are using the BMC-CTRLM_server.xml file, skip the remainder of these steps.  Otherwise, open the 
apagent.xml configuration file in an XML editor.
AlarmPoint Java Client   |  8
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4. Modify the following line:

if( !APDT_data_center.trim().equalsIgnoreCase( "ALARMPOINT" ) )

• Replace the word ALARMPOINT with the name of the gateway running on the CONTROL-M/Server computer. A 
gateway will be configured in a later section.

5. Modify the following line:

return fieldMap.getValue( fields, "bsmith" );

6. Replace bsmith with the User ID of the target for notifications you specified in section “Setting up a two-way 
Device” on page 7.

7. Save the file.

3.3.3 Edit APAgent.xml
By default, the AlarmPoint Agent’s configuration file (APAgent.xml) is located in the C:\APAgent\etc subdirectory. 

1. Add or modify the alarmpoint-agent element in the APAgent.xml file  to include an id attribute that matches the 
name of the CONTROL-M/Server data center. For example, if your Gateway is named ALARMPOINT, change the line 
as follows:

<alarmpoint-agent version="1.0" mode="enterprise" id="ALARMPOINT">

2. Verify that the mode attribute of the alarmpoint-agent element is set appropriately for your deployment.

•  AlarmPoint Enterprise deployments use a value of enterprise; AlarmPoint Server deployments use a value of 
server.

3. Add a reference to the XML file configured in the “Copy and Configure the Integration XML Configuration File” 
section:

• Add a line near the end of the file similar to the following, replacing FILENAME with the configuration file 
chosen in the “Copy and Configure the Integration XML Configuration File” section:

<alarmpoint-agent-client id="ctrlm" filename="integrations/FILENAME" />

4. Save the file.

5. Restart the AlarmPoint Agent.

Note: This integration depends on the data center name provided by CONTROL-M/EM. The name must be unique for all 
CONTROL-M/Server gateways. AlarmPoint routes request messages from an AlarmPoint (Notification) Server to 
the appropriate AlarmPoint Agent based on the gateway’s name.

3.3.4 CONTROL-M/EM
The only configuration required for the CONTROL-M/EM application (with respect to the AlarmPoint Java Client) is to 
map job attributes to an AlarmPoint User or Group ID. Mapping job attributes to an AlarmPoint target requires modifying 
the job-target.map file in the AlarmPoint Java Client’s installation directory. 

The following sections provide a brief summary followed by a detailed technical overview explaining how to populate the 
contents of the mapping file. The mappings required for the integration example are in the mapping file by default.
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Note: The mapping file uses “bsmith” as the target User ID for all notifications. If you specified a different target for 
notifications in “Setting up a two-way Device” on page 7, replace all references to bsmith with the User ID of 
your notification target.

3.3.4.1 Mapping File Overview
The mapping file consists of comma-delimited fields that are matched against incoming event data to determin who to notify 
about each event. The fields are defined as follows:

The four fields above must appear on a single line in the file. For example:

payroll, accounting, HR, operations group

3.3.4.2 Mapping File Rules and Restrictions
The mapping file uses Java regular expressions (regex) when matching fields. Consider the following examples of the 
wildcard (*) matching:

.*, accounting, HR, operations

.*, CRITICAL.*, HR, operations
netmon, 10.10.10.*, .*, network

Note: The comparisons are case-sensitive; e.g., “accounting” will not match “Accounting” or “ACCOUNTING”.

For a complete explanation of regex used by the mapping file, see the Java resource at the following URL:

http://java.sun.com/j2se/1.5.0/docs/api/java/util/regex/Pattern.html

3.3.4.3 Mapping File Implementation Details
The number of fields can be changed, but it must be consistent throughout the mapping file. For example, it is possible to use 
JOBNAME, APPLICATION, and GROUP for finding an AlarmPoint ID, without including the remaining details. However, 
the entire file must then be limited to four fields:

jobname,application,group,id

It is possible to include more fields:

jobname,application,group,severity,id

The names of the fields are not important, but their order must be consistent. Using this data map feature, the integration 
relies on the given criteria (I.e job, application, group). The following lines are in the default BMC-
CTRLM_enterprise.xml (or BMC-CTRLM_cohost.xml, depending on your CONTROL-M deployment):

Field Description

Job name Name of the CONTROL-M job that generated an event

Application Name of the application for the CONTROL-M job

Group Group associated with the CONTROL-M job

Target AlarmPoint person or group ID that should be notified when a CONTROL-M event is generated
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fields.add( jobName );
fields.add( app );
fields.add( group );

Adding severity as a field requires another line:

fields.add( severity );

There is no limit on the number of fields, but the mapping file must be updated accordingly.

3.4 BMC CONTROL-M System

Note: The following sections are intended for use with BMC CONTROL-M version 6.301. Earlier versions may require 
slightly different workflow or control. Please refer to your BMC user documentation.

Before configuring CONTROL-M, the following applications must be installed: 

• CONTROL-M/EM 

• CONTROL-M/Desktop

• Administration Facility

Note: The Machine Name, when required, is case-sensitive.

3.4.1 Communication Administration

3.4.1.1 Configure a Gateway
1. Open the CONTROL-M Configuration Manager.

2. Select Components > New > CONTROL-M/Server and Gateway.

3. Select Define.

4. The following are used for this integration:

• Name: ALARMPOINT

• ID: INV

• Platform: Distributed

• Version: 630

5. Under Communication, enter the following information:

• Protocol: TCP

• Host: name of the current host

• CONTROL-M/EM Port: 2370

6. Under Gateway, click New, and accept the provided values.

7. Click OK to save the changes and exit.
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3.4.2 Example Batch Job Installation

3.4.2.1 Create and Schedule a Job
1. Open the CONTROL-M Desktop Application.

2. To create a new job, click Edit > New Job.

3. Do one of the following: 

• In Windows, enter the form details as illustrated by the following figure:

• In Unix, in the Command text box, type a name for a shell script that does not exist, e.g., nonexistent.sh.

4. Click Save & Order, and then set the parameters as illustrated in the following figure:
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5. Click Order.

• If the Scheduling Table you are using already exists, CONTROL-M displays the following dialog box:

6. Select the check box next to the scheduling table, and then click Continue.

• If the job is scheduled successfully, CONTROL-M displays the Job Action Report dialog box:
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7. Exit the CONTROL-M Desktop Application.

3.4.2.2 Set System Parameters
1. Open the Configuration Manager:

2. Select Tools > System Parameters.

• CONTROL-M/EM must be configured to run the APClient binary to send an Alert into the AlarmPoint System.

3. Scroll down and double-click SendAlarmToScript:
BMC CONTROL-M System   |  14



ConfigurationAlarmPoint for BMC CONTROL-M
4. In the Value text box, enter the path to APClient.bin.

Unix: 

/home/emuser/alarmpoint/APClient.bin --map-data ctrlm

Note: The /home/emuser value in the path should point to the CONTROL-M/EM’s home directory. For example, in 
CONTROL-M/EM version 6.1.03, the default path may be /home/em613. Change the SendAlarmToScript value 
accordingly.

Windows:

C:\APAgent\APClient.bin.exe --map-data ctrlm

Note: In version 6.103 on Windows, the path portion of the command must be enclosed in double quotes, as shown in the 
following example:
“C:\APAgent\APClient.bin.exe” --map-data ctrlm
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5. Click Save.

6. Double-click SendSnmp and change its Value to 1.

• This value controls whether the alert is sent out via SNMP, to a script (or another application), or both. Possible 
values include:

• 0 SNMP Trap

• 1 Script

• 2 SNMP Trap and Script

7. Click Save.

8. Click Close to close the System Parameters dialog box.

9. Restart the Gateway component from the Administration Facility:

• Select the Gateway.

• Set the Desired State to Down (click the down-arrow button).

• Wait for the Current State to indicate Down.

• Set the Desired State to Up (click the up-arrow button).

• Wait for the Current State to indicate Up.

Note: When a change is made to the System Parameters, the Gateway must be restarted.

3.5 Software Component Validation
Depending on the Operating System, there are two ways to check the connectivity of the AlarmPoint Agent. Both examples 
presume a default installation.

• Unix: type the following from a shell prompt: 

/home/controlm/alarmpointsystems/APAgent/APAdmin --get-status

• Windows: open a command prompt (Start > Run > cmd > OK), then type the following:

C:\APAgent\APAdmin --get-status

You should see that the connection is established. If not, there is a configuration or connectivity problem between the
AlarmPoint Agent and AlarmPoint. Review the user manual for troubleshooting.

Note: The recommended way to start the AlarmPoint Agent under Unix is by using the alarmpoint-java-client 
shell script. Under Windows, the AlarmPoint Java Client should be installed as a Service.
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4. Software Component Integration

4.1 Trigger a Notification
The following steps demonstrate the process of generating a notification from a CONTROL-M/EM Alert:

1. Open CONTROL-M/EM:

2. Select File > Open ViewPoint.

3. Select All Active Jobs.

4. Click OK.

5. In the right pane, right-click ALARMPOINT and select Expand. Repeat this process for UnixAppl (or WinAppl on 
Windows), and for UnixJobs (or WinJobs):

• CONTROL-M indicates that there was a problem with a job. There has not been an Alert sent into the AlarmPoint 
System because the job ran before CONTROL-M was configured to run the APClient binary.

6. Right-click failure.sh ALARMPOINT and click Rerun.
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• CONTROL-M calls the APClient binary for the next Alert it generates. In turn, this will trigger a notification to the 
AlarmPoint (Notification) Server.

7. Click Yes to confirm.

4.2 Initiate a Notification Request
1. On the AlarmPoint (Notification) Server, the Virtual Two-Way pager device shows information about the CONTROL-

M Alert:

2. To view the entire message, click the down-arrow button on the right side of the Virtual Pager device.

3. Click the check mark button, and then click REPLY.

4. Click HOLD.

There are several response options, all of which act on the job that triggered the notification. These include:

• HOLD – Pause the job

• FREE – Resume the job

• RERUN – Try running the job again

• CONFIRM – Allow processing to continue

• FORCEOK – Set the job status to OK

• DONE – Indicate that the situation has been handled
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If you configure your target AlarmPoint User to receive Virtual E-mail notifications, you will see two more possible request 
actions:

• SYSOUT – Request the information returned from a ctmpsm LISTSYSOUT command

• LOG – Request the logging information returned from the ctmlog command, for the given order number

The SYSOUT and LOG request options are available only from two-way e-mail notifications (because they return a 
significant amount of textual information). Consult the user manual for details on how to create AlarmPoint System accounts 
that can send and receive e-mail notifications.

Note: You must reply with DONE when finished interacting with the system to indicate that no further actions are 
required.

4.3 View Request Results
To view the results of the hold request, switch to CONTROL-M/EM. The failure.sh job now has a lock icon indicating 
the job is currently on hold:
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5. Frequently Asked Questions

5.1 What does “java.io.IOException: Not enough space” mean?
This means the temporary directory has run out of disk space. To resolve this issue, increase the amount of free disk space 
under /tmp (or the location of the temporary directory). Under Windows, make sure the drives have enough free disk space.

5.2 Why are the logs sent by e-mail missing information?
Each element within each message has a limit of 2000 characters. This is constrained by the size of database columns in the 
AlarmPoint System.

5.3 What do I do when I have an incompatible version error?
This error sometimes occurs if the job skeleton you are using has a default CONTROL-M definition specifying an older 
version of CONTROL-M than you are using. To fix this problem, change the job skeleton’s default CONTROL-M definition 
to one using your version of CONTROL-M.

5.4 How do I change a job skeleton’s default CONTROL-M definition?
1. Open the CONTROL-M Desktop.

2. Click Tools > Skeleton.

3. Use the  Skeleton Name drop-down list to select the sketon you want to modify.

4. Use the CONTROL-M drop-down list to specify the new CONTROL-M definition.

5. Clcik OK.

5.5 How do I change the version of a CONTROL-M definition?
1. Open the CONTROL-M Desktop.

2. Click Edit > CONTROL-M Definitions.

3. Select the dfefinition to update.

4. Click Update.

5. Use the drop-down list to change the version.

6. Clcik OK.
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6. Troubleshooting
Consult the following checklist to help identify and resolve some common AlarmPoint - BMC CONTROL-M integration 
issues.

6.0.1 Verify that AlarmPoint is installed and running.

To verify:

1. Sign in to AlarmPoint as a Super Administrator.

2. On the Admin tab, click Nodes and Device Engines.

3. Ensure that all Nodes are active and running.

6.0.2 Verify that AlarmPoint can send notifications.

To verify:

1. Sign in to AlarmPoint.

2. Click the Messaging tab, and use the Quick Message form to send a test notification.

6.0.3 Verify that each AlarmPoint Java Client is pointing to and communicating 
with AlarmPoint.

To verify:

1. Open the APAgent.xml file located in the etc subdirectory where Java Client is installed and confirm the following:

• The integration entry for ctrlm exists and points to the appropriate integration file depending on the CONTROL-M 
components installed as shown below:

<alarmpoint-agent-client id="ctrlm" filename=... />

• The gateway name matches the name in the integration file (see section 3.3.2.1 for details).

• The address= attribute contains either the hostname or IP of the machine where AlarmPoint is running, and that 
the port is 2004, as shown below:

<server type="primary" address="192.168.168.64" port="2004" />

• If using failover configuration, the "secondary" type points to the secondary AlarmPoint Server.

2. To verify that the AlarmPoint Java Client is connected to AlarmPoint (refer to section 3.5 for details) type the 
following into the command line:

APAdmin --get-status

6.0.4 Confirm the location of integration files.
The job-target.map file must be located in the APAgent install directory.
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6.0.5 CONTROL-M/EM, CONTROL-M/Agent, and CONTROL-M/Server must all 
be installed and running.

• Verify that all required CONTROL-M/EM components are installed and running.  

• Verify that the version for all components is 6.1.03 or greater. 

• Verify that the directories containing the following commands are included in the system path:

• ctmpsm

• ctmlog

• ctmkilljob

6.0.6 Check the CONTROL-M/EM configuration.
Ensure that CONTROL-M/EM has been configured as follows: 

• There is a GATEWAY that matches the name specific in the integration file (e.g., "ALARMPOINT").

• SendAlarmToScript system parameter points to APClient.bin.

• SendSNMP system parameter is set to "1" (application).
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7. Contact Us
You can access the AlarmPoint Systems Web Site at http://www.alarmpoint.com. From this site you can obtain information 
about the Company, the Products, Support and other helpful information. You may also access the Customer Support Site 
from the main web page. In this protected site you will find current product releases, helpful hints, patches, release notes, a 
helpful product knowledge base, trouble ticket submission areas and other helpful tools provided by AlarmPoint Systems, 
Inc. 

AlarmPoint Systems, Inc.
4457 Willow Road, Suite 220
Pleasanton, CA 94588

Phone: 925-226-0300 
Fax: 925-226-0310

Email: support@alarmpoint.com
Website: http://www.alarmpoint.com 

BMC Software, Inc.
2101 CityWest Blvd.
Houston, TX 77042-2827

Phone: 800-841-2031
Fax: 713-918-8000

E-mail: support@bmc.com
Website: http://www.bmc.com/products
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8. Copyright
AlarmPoint Systems, Inc. and BMC Software Inc. produced this integration document to assist customers with joint BMC/
AlarmPoint Systems implementations. BMC and AlarmPoint Systems have made every effort to ensure that the information 
contained in this document is accurate, but do not guarantee any accuracy now or in the future.

AlarmPoint Systems™ and AlarmPoint® are a trademark and registered trademark, respectively, of AlarmPoint Systems, 
Inc. in the United States, United Kingdom and other jurisdictions. CONTROL-M, CONTROL-M/Agent, CONTROL-M/
Server, and CONTROL-M/EM are registered trademarks or trademarks of BMC Software, Inc. All other trademarks are the 
property of their respective owners.

©AlarmPoint Systems 2010. Rights to reproduce this document only by written permission of AlarmPoint Systems.
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