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Chapter 1: Introduction
Welcome to xMatters (alarmpoint) for IBM Tivoli Change and Configuration Management Database. This document

describes how to install and configure the xMatters (alarmpoint) for IBM Tivoli Change and Configuration

Management Database software integration. The intended audience for this document is experienced consultants,

system administrators and other technical readers.

1.1 Summary
xMatters is an interactive alerting application, designed to capture and enrich important events, to route those events

to the right person on any communication device, and to give that person the ability to solve, escalate, or enlist

others to resolve the events remotely.

xMatters allows you to take critical business information and contact the right people via voice phone, SMS, two-

way pagers, instant message, and email.

Through integration modules, xMatters can become the voice and interface of an automation engine or intelligent

application (the management system, such as IBM Tivoli Change and Configuration Management Database). When

Tivoli detects something that requires attention, xMatters places phone calls, sends pages, messages, or emails to the

appropriate personnel, vendors or customers.

xMatters is also persistent, escalating through multiple devices and personnel until someone accepts responsibility or

resolves the problem. Once contacted, xMatters gives the notified person instant two-way communication with IBM

Tivoli Change and Configuration Management Database. Responses are executed immediately on Tivoli, enabling

remote resolution of the event.

This integration supports workflow assignment notifications (from Tivoli to xMatters) through the Maximo

Enterprise Adapter. It also supports inbound actions (from xMatters to Tivoli) to accept, reject, or re-assign the

originating workflow assignment.

You will need to modify this configuration to suit your particular business requirements and adjust it to suit your

expected loads. For example, the default integration features automatic status annotations to the original event; in a

high-volume production system, this can significantly affect performance. Consider your expected volume of

injected events and your server capacity when designing your own integration with xMatters.

1.1.1 Benefits
With the xMatters integration, the appropriate technician can be notified directly via voice, email, pager,

BlackBerry, or other device. Information about the failure will be presented to the event resolver and decisions can

be made in real-time.

Once a response is selected on the recipient’s remote device, xMatters will update the workflow assignment in real-

time. The benefit is that this process is immediate – significantly faster than the time required for staff to notice the

failures or malfunctions, determine who is on call, and manually notify the right person. In addition, the ability to

take simple actions on the event from any device gives the event resolver a quick way to deal with many issues and

communicate to other team members the current state of the event.

During the process, every notification, response, and action is logged in xMatters. In addition, xMatters

automatically annotates the original workflow assignment with status information.

The xMatters product features a self-service web user interface to allow accurate assignment of responsible personnel

for each job. xMatters also includes an optional enhanced Subscription panel that allows both managed and self-

subscription to workflow assignments. This Subscription panel queries the Tivoli Server directly in real time to

retrieve lists of important settings and criteria, removing the need to create and maintain these lists.
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1.1.2 Integration Architecture
The software components in this integration include:

l xMatters (alarmpoint) engine

l IBM Tivoli Change and Configuration Management Database

l Maximo Enterprise Adapter

l xMatters integration agent

The following diagram illustrates the software processes used by this integration:

When a Tivoli workflow assignment is created, it triggers the following steps (the step numbers correspond to the architecture

diagram above):

1. When the workflow assignment is created, a new record is written to the WFASSIGNMENT table in Tivoli.

2. If the workflow assignment has an associated communication template, a new communication is created.

3. If the communication template has been flagged to communicate using xMatters and the workflow assignment has been

flagged to send a communication, a new event will be injected into the integration agent.

4. The integration agent determines what type of event has been received (a general communication or workflow

assignment). The integration agent will enrich the workflow assignment with the related change information and inject

a new event into the xMatters (alarmpoint) engine for notification..

5. The integration agent uses MEA web service calls to update the workflow assignment within Tivoli.

Assignments and events job control
Depending on the configuration of the workflow task and its associated communication template, an assignment task may be

injected into xMatters every time one is created within a workflow. This means that it is possible that multiple events may

be created in xMatters for a single change record, depending on the number of notifications that Tivoli determines should be

sent out.

To handle this possibility, the unique "event ID" used in xMatters is associated with the ID of the assignment, rather than

with the ID of the change to which the assignment relates. The following sections describe how this design affects the

termination of events and changes to the originating workflow assignment.
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When a User accepts or rejects an assignment, xMatters "delinks" all Users from the event. This is because the assignment is

targeted; even if the target of the notification is an xMatters Group, the first person to accept or reject the assignment is

responding on behalf of the targeted Group, and the assignment is no longer active in Tivoli.

The following sections clarify how responses from xMatters affect the workflow assignment status in Tivoli. Note that the

following are based on the functionality of the Tivoli workflow; these are not rules defined by the integration and are not

customizable within the xMatters (alarmpoint) for IBM Tivoli Change and Configuration Management Database integration.

When an assignment is accepted, the record status for the assignment is set to "COMPLETE". If the assignment is of the type

"When any assignment is accepted", the process sets all remaining assignments for the workflow task to "INACTIVE". If the

assignment task is of the type "When ALL assignments are acccepted", the process updates only the current assignment to

COMPLETE; all other assignements for the task are left as "ACTIVE".

When an assignment is rejected, the assignment record status is set to "COMPLETE", and all other assignment records for the

workflow are set to "INACTIVE". The workflow is STOPPED.

When an assignment is reassigned, the record status is set to "FORWARDED". The assignment record is still valid, as are all

other assignments for the workflow task.

The act of setting a workflow assignment to "COMPLETE" or "INACTIVE" terminates the corresponding event in xMatters.

Note also that when defining roles that are being used in workflow assignments or Communication Templates, if the

Communication Template has been defined to use xMatters for notifications, the role must be of Type Person or Person

Group.

1.2 System Requirements
The following products must be installed and operating correctly prior to integration:

l xMatters (alarmpoint) engine 4.1 (patch 006 or later)

l xMatters integration agent 4.1 (patch 003 or later)

l xMatters Developer IDE

l IBM Tivoli Change and Configuration Management Database version 7.1 or 7.2

1.2.1 Operating Systems
The following operating systems are supported by this integration:

l Microsoft Windows 2003 (validated)

l Microsoft Windows 2008 (validated)

l Sun Solaris 10

l HP-UX B.11.23

l AIX 5.3 (validated)

l Linux Redhat AS/ES 5.3

1.3 Conventions and Terminology
This section describes how styles are used in the document, and provides a list of definitions.

1.3.1 Conventions
Some instructions appear in the following format: MENU > OPTION; for example, File > Open means click the File menu,

and then click the Open menu option.

Words in bold typically reference text that appears on the screen. Words in monospace font represent the following:
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l text that must be typed into the computer

l directory and file names

l code samples

Directory paths
Except where explicitly stated, the directory paths in this document are listed in Windows format. Unix users must substitute

the given paths with the Unix equivalents.

The xMatters installation folder is referred to throughout the documentation as <xMHOME>.

l On Windows systems, the default is C:\Program Files\AlarmPointSystems\AlarmPoint\

l On Unix systems, the default is /opt/alarmpointsystems/alarmpoint/

The xMattersintegration agent installation folder is referred to throughout the documentation as <IAHOME>.

l On Windows systems, the default is C:\Program Files\AlarmPointSystems\IntegrationAgent\

l On Unix systems, the default is /opt/alarmpointsystems/integrationagent

1.3.2 Terminology
The following terms are used through the xMatters documentation.

Term Meaning

Event An event refers to any situation or item of interest detected by the management system, and which

requires attention. Event is also used to refer to the incident or situation as it progresses through the

xMatters system, from injection to notification to resolution. Each event must generate at least one

alert or notification.

Event can also be a generic term used to refer to an incident, change request, message, or other

specific item within the management system. Whenever possible, these situations are referred to

using the management system's preferred terminology, but can also collectively be called events.

Management system A management system is any sort of monitoring or managing software that watches for events, and

with which xMatters can combine; i.e., a synonym for Tivoli.

Device The medium through which a recipient is contacted by xMatters; i.e., email, pager, phone,

BlackBerry, etc.

User In xMatters, people who can receive notifications are called "Users". Each person in the xMatters

system is defined by a set of User details, including ID number, user name, login password, and so

on.

Group Groups are used to collect and organize Users and Devices into notification schedules. For a

complete explanation of Groups in xMatters, see the xMatters (alarmpoint) engine user guide.

Documentation terminology
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Chapter 2: Installation and Configuration
This chapter provides information about installing the xMatters (alarmpoint) for IBM Tivoli Change and Configuration

Management Database integration. This chapter also contains complete instructions on how to configure xMatters, Tivoli,

and the integration components.

2.1 Installing integration components
The following table describes some of the notable integration components:

Component Name Description

tivoli-ccmdb.js Integration script containing Response Action Scripting to handle response updates

through web service calls.

tivoli\conf\* The configuration files used to modify the behavior of event injection and Data

Synchronization.

tivoli\jsp\* The custom pages used within the Tivoli interface.

xM-IBM-Tivoli-CCMDB.aps xMatters scripts required for the integration.

tivoli-phone-regex.xml This file allows users to define multiple regular expressions to parse phone numbers

for injection into xMatters. The file contains comments explaining how to extend the

XML to add additional expressions.

Integration components

2.1.1 Installing the integration service files
To enable the Tivoli integration service, you must copy the folder containing the integration agent files into the xMatters

integration services folder and modify the tivoli-ccmdb.js and IAConfig.xml files. If you have more than one integration

agent providing the Tivoli service, repeat the following steps for each one.

To install the integration service:

1. Copy the xM-IBM-Tivoli-CCMDB\components\alarmpoint-integration-agent\tivoli-ccmdb folder from the

extracted integration archive to the <IAHOME>\integrationservices folder.

2. Open the <IAHOME>\conf\IAConfig.xml file and add the following line to the “service-configs” section:

<path>tivoli-ccmdb/tivoli-ccmdb.xml</path>

3. Open the tivoli-ccmdb.js file (now located in <IAHOME>\integrationservices\tivoli-ccmdb\) and modify the

following variables to match your Tivoli installation.

Property Description

TIVOLI_URL The URL at which the integration agent can contact the Tivoli web services

TIVOLI_USER The Tivoli user to use for web service calls

TIVOLI_PASSWORD The Tivoli user’s password

4. Restart the integration agent.

Note: On Windows, the integration agent runs as a Windows Service; on Unix, it runs as a Unix daemon.
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2.1.2 Installing voice files
These files must be installed into any xMatters deployment running a voice Device Engine. For more information, refer to the

xMatters (alarmpoint) engine installation and administration guide.

To install the voice files:

1. Copy all of the files in the xM-IBM-Tivoli-CCMDB\components\alarmpoint\vox\english folder from the extracted

integration archive to the following node installs folder:

<XMHOME>\node\phone-engine\Datastore\domains\common\recordings\english\phrases

Note: This integration provides a complete set of English voice files.

2.1.3 Installing the WebSphere files
The integration includes configuration files for WebSphere, which must be copied to the correct location on the WebSphere

server, and edited to include the correct connection information.

To copy the configuration files:

1. Copy the xM-IBM-Tivoli-CCMDB\components\tivoli folder from the extracted integration archive to the

C:\xmatters (Windows) or /opt/alarmpointsystems (Unix) folder in the root directory of the server on which

WebSphere is running.

Note: If the \alarmpoint or /opt/alarmpointsystems directory does not exist, you will have to create it.

Updating tivoli.properties
The tivoli.properties file contains the URLs and passwords used to contact the xMatters web services, the integration

agent, and the Tivoli web services. Other configuration options included in the tivoli.properties file are described in

"Optimizing and Extending the Integration" on page 37.

To update the properties file:

1. On the WebSphere server, open the \xmatters\tivoli\conf\tivoli.properties file.

2. Update the following properties to match your configuration:

Property Description

ap_integration_agent_url The URL at which the Tivoli server can contact the integration agent.

ap_integration_configuration_path The path to the configuration XSL files (default value is

C:/xmatters/tivoli/conf/, which is the Windows default). This must be

modified for Unix or non-default Windows installations.

ap_url The URL used to communicate with the xMatters web server

ap_webservice_url The URL at which the Tivoli server can contact the xMatters web services.

Note: This field should not be modified from its default value.

ap_webservice_user The xMatters Web Service User to use for web service calls; default is "apwsu".

ap_webservice_password The xMatters Web Service User’s password; default is "password".

ap_webservice_company The xMatters Company to use for web service calls.
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Property Description

tivoli_webservice_url The URL at which the Initial User Sync can contact the Tivoli web services.

tivoli_webservice_user The Tivoli user to use for web service calls.

tivoli_webservice_password The Tivoli user’s password.

3. Save and close the file.

Updating time zone mappings
The Person.xsl file installed with the WebSphere files contains the mapping rules for converting the published Person data

into the web service XML processed by xMatters. As Tivoli has over 120 time zones defined, you must to define a mapping

of the time zones that are relevant to the installation in the Person.xsl file.

To add the mappings, open \xmatters\tivoli\conf\Person.xsl in a text editor and modify the <xsl:template

match="mx:TIMEZONE"> section.

The file includes a sample match, along with default values that will be used if a time zone is encountered for which no

explicit translation has been defined.

To add translations into the file, copy the node:

<xsl:when test="text() = 'America/Caracas'">

<ap:timeZone>Canada/Atlantic</ap:timeZone>

</xsl:when>

The <xsl:when> test value identifies the Tivoli value that will be matched. The <ap:timeZone> should contain the xMatters

time zone to which it should be mapped.

Note: If this file is not updated, the user time zones may not be correctly translated when synchronizing users between

Tivoli and xMatters.

Asia/Hong_Kong Canada/Yukon Europe/Vienna

Asia/Seoul Europe/Amsterdam Europe/Warsaw

Asia/Shanghai Europe/Athens Europe/Zurich

Asia/Singapore Europe/Berlin GMT

Asia/Taipei Europe/Brussels US/Alaska

Asia/Tokyo Europe/Budapest US/Aleutian

Australia/Melbourne Europe/Copenhagen US/Arizona

Australia/Perth Europe/Dublin US/Central

Australia/Sydney Europe/Helsinki US/East-Indiana

Canada/Atlantic Europe/Lisbon US/Eastern

Canada/Central Europe/London US/Hawaii

Canada/East-Saskatchewan Europe/Moscow US/Indiana-Starke

Canada/Eastern Europe/Oslo US/Michigan

Supported time zones
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Canada/Mountain Europe/Paris US/Mountain

Canada/Newfoundland Europe/Prague US/Pacific

Canada/Pacific Europe/Stockholm US/Samoa

Canada/Saskatchewan

2.1.4 Updating and re-deploying the Maximo EAR file
Before you can configure the integration components, you must add the custom libraries and associated configuration files to

the Maximo EAR file and update the buildmaximoear.xml file to reference the new files. After you install and update the

Maximo EAR file, you must set the configuration parameters, and then update the Maximo server.

Note: The following instructions assume the default Maximo installation directories; your deployment may vary.

To add the integration components for deployment with the Maximo EAR File:

1. Copy the com.xmatters.ibm.tivoli.jar and dom4j-1.6.jar files from the xmatters\tivoli\lib directory to

ibm\SMP\maximo\applications\maximo\lib.

2. Copy the contents of the xmatters\tivoli\jsp\ccmdb directory to ibm\SMP\maximo\applications\

maximo\maximouiweb\webmodule\webclient\alarmpoint\ccmdb.

l If the alarmpoint subfolder does not exist, you will need to create it.

To update the Maximo EAR deployment:

1. Open the ibm\SMP\maximo\deployment\buildmaximoear.xml file.

2. Locate the line that defines the maximo.businessobjectsclasspath property.

3. Update the value attribute to contain the following:

/lib/dom4j-1.6.jar /lib/com.xmatters.ibm.tivoli.jar

4. Save and close the file.

Updating the Maximo server
To update the Maximo server, you must rebuild and deploy the EAR file.

To rebuild and deploy the Maximo EAR:

1. Navigate to the ibm\SMP\maximo\deployment directory.

2. Run the buildmaximoear.cmd (on Windows) or the buildmaximoear.sh (on Unix) command.

3. Login to the WebSphere Integrated Solutions Console as an administrator (the default “wasadmin”).

4. On the left navigation bar, click Servers > Application Servers, and then stop the MXServer Application Server.

5. On the left navigation bar, click Applications > Enterprise Applications.

6. Select MAXIMO Application, and then click Update.

7. Select Replace the entire application.

l If the EAR file is located on a remote Maximo server, select Remote file system; if the EAR file is located on the

local machine, select Local file system.

8. Click Browse, and then select the new EAR file located at ibm\SMP\maximo\deployment\default\maximo.ear.

9. Click Next, and once processing is complete, click Next again.

10. Select Clusters and Servers, and then click Apply.

11. Select all of the available modules.
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12. Click Next, and then click Finish to deploy the new maximo.ear file.

13. Click Save and restart the MXServer Application Server.

2.2 Configuring Tivoli
To prepare IBM Tivoli Change and Configuration Management Database to combine with xMatters, configure the following

components :

l Web Application URL

l Object Structures

l Publish Channels

l Web Services

l End Points

l External Systems

l Database

l Logging (optional)

l Launch In Context

l Applications

l Security Groups

l Messages

2.2.1 Configuring the Web Application URL
This section configures the URL of the web application

1. Log into the Service Request Manager Console and, using the Go To menu, select System Configuration > Platform

Configuration > System Properties.

2. Enable the Global Properties filter (click the triangular icon near the Filter text), type mxe.int.webappurl, and then

press Enter.

3. Expand the mxe.int.webappurl row and change the Global Value to the location of the Tivoli server’s MEA web

URL.

l Ensure that the port value specified is correct.

4. Click Save, and then restart the MXServer Application server.

2.2.2 Configuring the Object Structures
This section describes the Object Structures you must define within Tivoli.

To create the Integration Objects:

1. Log into the Maximo Console, and using the Go To menu, select Integration > Object Structures.

2. Click New Object Structure.

3. Enter the Object Structure’s information into the fields as described in the tables below.

l To add a Source Object, click New Row, and enter the required information as described in the tables.

4. Click Save.

Repeat the above steps for each Object Structure identified below.

Object Structure: XMASSIGNMENT

l Long Description: XMatters: Object Structure for WFASSIGNMENT and COMPLETEWF

l Consumed By: INTEGRATION
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l Inbound Processing Class: com.xmatters.ibm.tivoli.workflow.XMattersWorkflowInboundProcessor

l Support Flat Structure: true

Object Parent Path Relationship Order User Defined

WFASSIGNMENT WFASSIGNMENT 1 true

COMPLETEWF WFASSIGNMENT WFASSIGNMENT/

COMPLETEWF

COMPLETEWF 1 true

REASSIGNWF WFASSIGNMENT WFASSIGNMENT/

REASSIGNWF

REASSIGNWF 2 true

Object Structure: XMCHANGE

l Long Description: XMatters: Object Structure for WOCHANGE

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

WOCHANGE WOCHANGE 1 true

WORKLOG WOCHANGE WOCHANGE/WORKLOG MODIFYWORKLOG 1 true

CI WOCHANGE WOCHANGE/CI CI 2 true

Object Structure: XMTASK

l Long Description: xMatters: Object Structure for WFTASK

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

WFTASK WFTASK 1 true

Object Structure: XMCI

l Long Description: xMatters: Object Structure for Configuration Items

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

CI CI 1 true

Note: If you have already installed the IBM Tivoli Service Request Manager integration, these objects may already exist in

Tivoli. You do not need to redefine them, and can skip the remaining Object Structures; they are for the Data

Synchronization feature, which is a shared component.

Object Structure: XMPERSON

l Long Description: xMatters: Object Structure for PERSON

l Consumed By: INTEGRATION
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Object Parent Path Relationship Order User Defined

PERSON PERSON 1 true

PHONE PERSON PERSON/PHONE PHONE 1 true

EMAIL PERSON PERSON/EMAIL EMAIL 2 true

SMS PERSON PERSON/SMS SMS 3 true

Object Structure: XMUSER

l Long Description: xMatters: Object Structure for User

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

MAXUSER MAXUSER 1 true

EMAIL MAXUSER MAXUSER/EMAIL EMAIL 1 true

PHONE MAXUSER MAXUSER/PHONE PHONE 2 true

Object Structure: XMPERSONGROUP

l Long Description: xMatters: Object Structure for PERSONGROUP

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

PERSONGROUP PERSONGROUP 1 true

PERSONGROUPTEAM PERSONGROUP PERSONGROUP/

PERSONGROUPTEAM

ALLPERSON

GROUPTEAM

1 true

Object Structure: XMPERSONGROUPTEAM

l Long Description: xMatters: Object Structure for PERSONGROUPTEAM

l Consumed By: INTEGRATION

Object Parent Path Relationship Order User Defined

PERSONGROUPTEAM PERSONGROUPTEAM 1 true

2.2.3 Configuring the Publish Channels
This section describes the Publish Channels you must configure within Tivoli.

To create the Publish Channels:

1. In the Maximo Console, using the Go To menu, select Integration > Publish Channels.

2. Click New Publish Channel.

3. Enter the Publish Channel’s information into the fields as described below.

4. Select Action > Enable Listener, and then click OK on the system message.

5. Click Save.

Repeat the above steps for each Publish Channel identified below, and then restart the Tivoli server.



xMatters (alarmpoint) for IBM Tivoli Change and Configuration Management Database

Chapter 2: Installation and Configuration | 12

Publish Channel: XMCHANGE

l Adapter: MAXIMO

l Operation: Publish

l Object Structure: XMCHANGE

l User Exit Class: com.xmatters.ibm.tivoli.ccmdb.XMattersWOChangeExit

l Event Filter Class: com.xmatters.ibm.tivoli.ccmdb.XMattersWOChangeEventFilter

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip the remaining

Publish Channels; they are for the Data Synchronization feature, which is a shared component.

Publish Channel: XMPERSON

l Adapter: MAXIMO

l Operation: Publish

l Object Structure: XMPERSON

l User Exit Class: com.xmatters.ibm.tivoli.datasync.AlarmPointPersonExit

Publish Channel: XMUSER

l Adapter: MAXIMO

l Operation: Publish

l Object Structure: XMUSER

l User Exit Class: com.xmatters.ibm.tivoli.datasync.AlarmPointPersonExit

Publish Channel: XMPERSONGROUP

l Adapter: MAXIMO

l Operation: Publish

l Object Structure: XMPERSONGROUP

l User Exit Class: com.xmatters.ibm.tivoli.datasync.AlarmPointPersonGroupExit

Publish Channel: XMPERSONGROUPTEAM

l Adapter: MAXIMO

l Operation: Publish

l Object Structure: XMPERSONGROUPTEAM

l User Exit Class: com.xmatters.ibm.tivoli.datasync.AlarmPointPersonGroupTeamExit

2.2.4 Configuring the Web Services
The following steps describe how to configure the web services required for the integration.

To create the Web Services:

1. In the Maximo Console, using the Go To menu, select Integration > Web Services Library.

2. Click Select Action > Create Web Service > Create WS from Object Structure.

3. In the dialog box, select XMPERSON, XMPERSONGROUP, XMPERSONGROUPTEAM, XMASSIGNMENT,

XMCHANGE, XMTASK and XMCI.

4. Click Create.

5. Select the Select Records check box at the bottom of the list.
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6. Select all of the new web services you added.

7. Click Select Action > Deploy Web Service.

2.2.5 Configuring the End Point
The following steps describe how to configure the End Point required for the integration.

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip this section.

To create the End Point:

1. In the Maximo Console, using the Go To menu, select Integration > End Points.

2. Click Select Action > Add/Modify Handlers.

3. Click New Row, and then type the following values into the form:

l Handler: XMHANDLER

l Consumed By: INTEGRATION

l Handler Class Name: com.xmatters.ibm.tivoli.AlarmPointNullHandler

4. Click OK.

5. Click New End Point, and then type the following values into the form:

l End Point: XMENDPOINT

l Description: xMatters Integration End Point

l Handler: XMHANDLER

6. Click Save.

2.2.6 Configuring the External System
The following steps describe how to configure the External System required for the integration.

To create the external system:

1. In the Maximo Console, using the Go To menu, select Integration > External Systems.

2. Click New External System, and then type the following values into the form:

l System: xMatters

l Description: xMatters: External System for Integration

l End Point: XMENDPOINT

l Outbound Sequential Queue: jms/maximo/int/queues/sqout

3. Select the Enabled check box.

4. Select the Publish Channels tab, and then click Select Channel.

5. In the dialog box, select XMCHANGE, XMPERSON, XMUSER, XMPERSONGROUP, and

XMPERSONGROUPTEAM.

6. Click OK, and then enable all of the Publish Channels.

7. Click Save.

2.2.7 Configuring the database
Configuring the database requires two sets of changes: configuring for data synchronization, and configuring for workflow.

Once you have finished the configuration, apply the changes to the database.

To configure the database for data synchronization:

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip these steps.
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1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration > Database

Configuration.

2. Select the PERSON Object (in the List tab, type PERSON into the Object field, press Enter, and then select the

PERSON link).

3. Click the Attributes tab, and then click New Row.

4. Add a new attribute to the table:

l Attribute: XMATTERS_DEVICETRIGGER

l Description: A trigger field for the xMatters integration

l Type: ALN

l Length: 50

5. Leave all other values as the default values and click Save.

6. Repeat the above steps for the MAXUSER Object.

7. Update the EMAIL, PHONE and SMS Objects to use the custom MBOs as follows:

8. For each of the Devices, select the Device object, and then click the Object tab and modify the Class attribute:

l EMAIL Object Class: com.xmatters.ibm.tivoli.datasync.AlarmPointEmailSet

l PHONE Object Class: com.xmatters.ibm.tivoli.datasync.AlarmPointPhoneSet

l SMS Object Class: com.xmatters.ibm.tivoli.datasync.AlarmPointSMSSet

9. Click Save after modifying each object.

To configure the database for workflow:

1. In the Database Configuration area, select the COMMTEMPLATE Object (in the List tab, type COMMTEMPLATE into

the Object field, press Enter, and then select the COMMTEMPLATE link).

2. Click the Attributes tab, and then click New Row.

3. Add a new attribute to the table:

l Attribute: XMATTERSFLAG

l Description: Boolean flag to indicate whether to use xMatters as the Communication Template Processor

l Type: YORN

l Length: 1

l Scale: 0

l Required: true

l Title: Use xMatters

l Default Value: 1

l Alias: XMATTERSFLAG

Note: Setting the Default Value to 1 enables xMatters as the communication protocol for all communication templates. If

you want to configure each template separately, set the Default Value to 0; if you want to use xMatters as the

communication protocol for a template, you will have to manually edit the template and set the xMatters flag.

4. Click the Object tab, and change the Class attribute to the following:

com.xmatters.ibm.tivoli.commtmplt.XMattersCommTemplateSet

5. Click Save.

6. Select the WFASSIGNMENT Object (in the List tab, type WFASSIGNMENT into the Object field, press Enter, and then

select the WFASSIGNMENT link).

7. Click the Object tab, and change the Class attribute to the following:

com.xmatters.ibm.tivoli.workflow.XMattersWFAssignmentSet
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8. Click Save.

9. Select the COMPLETEWF Object (in the List tab, type COMPLETEWF into the Object field, press Enter, and then select

the COMPLETEWF link).

10. Click the Attributes tab, and then change the length of the Memo field to 100.

11. Click Save.

l Note that this change will automatically apply to the REASSIGNWF Object, and any other Objects that inherit

this field.

To apply the changes:

1. Return to the List tab and click Select Action > Manage Admin Mode.

2. Turn the Admin Mode ON.

l Note that this function may take a few moments. Click Refresh Status periodically until the following

confirmation is returned: BMXAA4002E - Admin Mode is ON for this server.

3. Click Select Action > Apply Configuration Changes.

4. Select the Do you have a current backup? check box to confirm a backup is available.

5. Click Start Configuring the Database.

l Click Refresh Status periodically until the following confirmation is returned: BMXAA0577E - Database

configuration is complete. You may view the log file to see the detailed status.

6. Click Select Action > Manage Admin Mode.

7. Click Turn Admin Mode OFF.

l It is important to complete this step, as leaving Admin Mode ON will prevent Tivoli from publishing events to

xMatters.

8. Click Refresh Status periodically until the following confirmation is returned: BMXAA4003E - Admin Mode is OFF

for this server.

2.2.8 Configuring Logging
The integration supports the log4j logging framework and can be configured using the standard Maximo logging

configuration page. Note that the following steps are optional, and not required for the integration to function.

To configure logging:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration > Logging.

2. Click Select Action > Manage Appenders.

3. In the dialog box, click New Row and then type the following values into the form:

l Appender: XMAppender

l Description: xMatters: RollingFileAppender for Integration

l Appender Implementation Class: psdi.util.logging.MXFileAppender

l File Name: xmatters.log

4. Click OK.

5. In the Root Loggers table, click New Row, and then type the following values into the form:

l Logger: com.xmatters

l Log Level: ERROR

l Key: log4j.logger.com.xmatters

l Appenders: XMAppender

6. Click Save, and then click Select Action > Apply Settings.

Note: For more detailed information in the log file, change the log level to INFO or DEBUG..



xMatters (alarmpoint) for IBM Tivoli Change and Configuration Management Database

Chapter 2: Installation and Configuration | 16

2.2.9 Configuring Launch In Context
The integration contains several custom JSP pages that can be launched via the Maximo Launch In Context feature.

To create the Launch In Context entries:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration > Launch In

Context.

2. Click New Launch Entry, and then enter the Launch Entry’s information into the fields as described below.

3. Click Save.

Repeat the above steps for each Launch Entry identified below.

Launch Entry Name: XMVIEWNOTIFICATIONS

l Description: xMatters View Notifications

l Console URL: /maximo/webclient/alarmpoint/ccmdb/ViewNotifications.jsp?operator={USER}

l Target Browser Window: alarmpoint

Launch Entry Name: XMSIGNON

Note that you do not need to configure this launch entry if you have already installed the IBM Tivoli Service Request

Manager integration.

l Description: xMatters Application Signon Screen

l Console URL: http://localhost:8888/xmatters (replace "localhost" with the appropriate URL for your installation)

l Target Browser Window: alarmpoint

Launch Entry Name: XMQUICKMESSAGE

l Description: xMatters Quick Message Screen

l Console URL:

/maximo/webclient/alarmpoint/ccmdb/QuickMessage.jsp?incidentId={WONUM}&amp;operator={USER}

l Target Browser Window: alarmpoint

Launch Entry Name: XMWHOISONDUTY

Note that you do not need to configure this launch entry if you have already installed the IBM Tivoli Service Request

Manager integration.

l Description: xMatters Who Is On Duty Screen

l Console URL:

/maximo/webclient/alarmpoint/ccmdb/WhoIsOnDuty.jsp?group={PERSONGROUP}&amp;operator={USER}

l Target Browser Window: alarmpoint

2.2.10 Configuring Applications
To use the Launch In Context entries defined above, you must add launch entries to the Change and PersonGroup

applications.

To update the Application:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration >

Application Designer.

2. In the Application filter, type CHANGE and press Enter.

3. Select the CHANGE Application, and then click Select Action > Add/Modify Signature Options.
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4. In the dialog box, at the bottom of the form, expand the Advanced Signature Options section, and then click New

Row.

5. Select the Associate to launch entry to enable launch in context check box, and then type the following values into

the form:

l Option: XMQM

l Description: xMatters Quick Message

l Launch Entry Name: XMQUICKMESSAGE

6. Click New Row again, select the Associate to launch entry to enable launch in context check box, and then type the

following values into the form (note that you do not need to configure this entry if you have already installed the IBM

Tivoli Service Request Manager integration.):

l Option: XMAPPL

l Description: xMatters Application

l Launch Entry Name: XMSIGNON

7. Click New Row again, select the Associate to launch entry to enable launch in context check box, and then type the

following values into the form:

l Option: XMVN

l Description: xMatters View Notifications

l Launch Entry Name: XMVIEWNOTIFICATIONS

8. Click OK, and then click Select Action > Add/Modify Select Action Menu.

9. Click New Row, and then type the following values into the form:

l Element Type: OPTION

l Key Value: XMQM

l Header Description: Quick Message

l Position: 1

l SubPosition: 1

l Tabs: MAIN

10. Click New Row again, and then type the following values into the form (note that you do not need to configure this

entry if you have already installed the IBM Tivoli Service Request Manager integration.):

l Element Type: OPTION

l Key Value: XMAPPL

l Header Description: xMatters Application

l Position: 2

l SubPosition: 1

l Tabs: MAIN

11. Click New Row again, and then type the following values into the form:

l Element Type: OPTION

l Key Value: XMVN

l Header Description: View Notifications

l Position: 3

l SubPosition: 1

l Tabs: MAIN

12. Click OK, and then click Save.
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Updating the PersonGroup Application
Note that you do not need to update the PersonGroup Application again if you have already installed the IBM Tivoli Service

Request Manager integration.

To update the Person Group Application:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration >

Application Designer.

2. In the Application filter, type PERSONGR and press Enter.

3. Select the PERSONGR Application, and then click Select Action > Add/Modify Signature Options.

4. In the dialog box, expand the Advanced Signature Options section, and then click New Row.

5. Select the Associate to launch entry to enable launch in context check box, and then type the following values into

the form:

l Option: XMONDUTY

l Description: xMatters: Who Is On Duty

l Launch Entry Name: XMWHOISONDUTY

6. Click OK, and then click Select Action > Add/Modify Select Action Menu.

7. Click New Row, and then type the following values into the form:

l Element Type: OPTION

l Key Value: XMONDUTY

l Header Description: Who Is On Duty

l Position: 1

l SubPosition: 1

l Tabs: MAIN

8. Click OK, and then click Save.

Updating the Communication Template
Note that when defining roles that are being used in Workflow Assignments or Communication Templates, if the

Communication Template has been defined to use xMatters for notifications, the role must be of Type Person or Person

Group.

To update the Communication Template Application:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration >

Application Designer.

2. In the Application filter, type COMMTMPLT, and then press Enter.

3. Select the COMMTMPLT Application, and then click the Workspace tab.

4. In the workspace, click the Communication Template tab.

5. In the toolbar, click Control Palette.

6. Click and drag a check box onto the form below the Comm Log Entry.

7. Right-click the new check box, and then select Properties.

8. In the Attribute field, set the value to XMATTERSFLAG, and then close the dialog box.

9. Save the changes to the form.

l Note that the caption is automatically set to the TITLE value specified in the attribute when it was added to the

database. When the form is loaded, the check box will be labelled as Use xMatters?
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2.2.11 Configuring Security Groups
Once you have added the action menu entries for the Applications, you must add permissions for the new entries to the

appropriate Security Groups. The following steps illustrate the process by explaining how to allow all users to access the

custom pages.

To add permissions to a Security Group:

1. In the Maximo Console, using the Go To menu, select Security > Security Groups.

2. In the Group filter, type EVERYONE and press Enter.

3. Select the EVERYONE Group, and then click the Applications tab.

4. Expand the filter for the Applications table, type Changes in the filter’s Description field, and then press Enter.

5. In the bottom table, select the Grant Access check box for the following items:

l xMatters Application

l xMatters Quick Message

l xMatters View Notifications

6. Click Save.

7. In the Applications description filter, type Person Groups, and then press Enter.

8. In the bottom table, select the Grant Access check box for xMatters Who Is On Duty (note that you can skip this step

if you have already installed the IBM Tivoli Service Request Manager integration.)

9. Click Save.

10. Log in as another user to confirm that the changes have taken effect.

Note: If you do not want all Users to have access to the custom pages, give permissions only to the appropriate Security

Groups.

2.2.12 Configuring Messages
In order for error messages to correctly be displayed to the user two custom messages must be added to the Maximo server.

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip this section.

To add the Messages:

1. In the Maximo Console, using the Go To menu, select System Configuration > Platform Configuration >

Application Designer.

2. Click the Workspace tab, and then click Select Action > Messages.

3. Click New Row, and then enter the following information:

l Message Group: alarmpoint

l Message Key: messagebox

l Display Method: MSGBOX

l Message ID: Click the Search tool and select Customer Customization.

l Display ID: Clear the check box.

l Value: {0}\nContinue?

l Buttons: Select the Yes and No checkboxes, and clear the OK check box.

4. Close the Message Group details section.

5. Click New Row again, and then enter the following information:

l Message Group: alarmpoint

l Message Key: statusmessage
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l Display Method: STATUS

l Message ID: Click the Search tool and select Customer Customization.

l Display ID: Clear the check box.

l Value: {0}

6. Click OK, and then click Save.

2.3 Configuring IBM WebSphere
To configure WebSphere, add the configuration files to the MXServer Application Server classpath.

Note: Even if you have already installed the IBM Tivoli Service Request Manager integration, you MUST add a new

classpath as described in the steps below, unless the entry you are adding already exists. Do not skip this section.

This section assumes you have already copied the WebSphere configuration files provided with the integration to the correct

folder on the WebSphere server, and configured the connection information, as described in "Installing the WebSphere files"

on page 6.

To add the configuration files to the classpath:

1. Log into the WebSphere Integrated Solutions Console, and click Servers > Application Servers.

2. Click the MXServer Name link.

3. In the right hand menu, select Server Infrastructure > Java and Process Management > Process Definition.

4. In the right hand menu, select Additional Properties > Java Virtual Machine.

5. In the Classpath text box, create a new line with C:\xmatters\tivoli\conf (or your Unix equivalent).

Note: This value must match the value specified in the ap_integration_configuration_path attribute in the

tivoli.properties file, as described in "Updating tivoli.properties" on page 6.

6. Click OK, and then click Save directly to the master configuration.

7. Restart the MXServer Application Server.

2.4 Configuring xMatters
Configuring xMatters to combine with Tivoli requires the following steps:

l Import the script package

l Configure the Event Domain

l Add a Web Service User

l Configure a supervisor

l Configure the Subscription Panel

l Configure Synchronization

2.4.1 Importing the script package
This step requires the xMatters Developer IDE. For installation instructions, refer to the xMatters Online Developer's Guide.

To import the xMatters script package:

1. Launch the xMatters Developer IDE, and then configure the database connection.

2. Click Workspace > Import.
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3. Select the xM-IBM-Tivoli-CCMDB\components\alarmpoint\scripts\xM-IBM-Tivoli-CCMDB.aps file extracted

from the integration zip file, click Open., and then click OK.

4. When the script has finished importing, click OK.

5. Click Database > Check Out.

6. In the Check Out dialog box, click Check Out.

7. In the Workspace pane, expand the Default Company > callout (CALLOUT) > PRODUCTION > CONTACT

folders, and then double-click the callout script.

8. At the top of the callout script, add the following line:

import com.invoqsystems.apex.component.broker.process.scriptObjects.ScriptObjectLinkedHashMap

9. In the callout script, locate the following line:

@initiatingEvent = @interaction::getInitiatingEvent()

10. Immediately after the initiaingEvent line, add the following:

GOSUB configureAdditionalESMTokens

11. Add the following code to the end of the script:

# Add any additional tokens required for the callout annotate here

configureAdditionalESMTokens:

@esmTokens = new ScriptObjectLinkedHashMap()

@script::log("Agent Client ID: " & $initiatingEvent.agent_client_id)

IF ($initiatingEvent.agent_client_id == "tivoli-ccmdb|tivoli-ccmdb")

@esmTokens::put( "incident_id" , $initiatingEvent.incident_id )

@esmTokens::put( "siteid" , $initiatingEvent.ch_site )

@esmTokens::put( "ownerid" , $initiatingEvent.as_ownerid )

ENDIF

RETURN

12. Locate each send() call in the script (there should be eight instances), and add the following code immediately

BEFORE each one:

$<varName>.additionalTokens = @esmTokens::getSerializedEntrySet()

Note: Replace <var_name> with the name of the ExternalServiceRequest object included in the send call. For an

example, see below.

13. Right-click the CONTACT:callout script and select Save.

14. Open the INTERACTION:authenticate script, and repeat step 12.

l Note that there are two instances of the ::send() call in the authenticate script.

15. Right-click the INTERACTION:authenticate script and select Save.

16. Right-click the CONTACT:callout script, and then select Validate.

17. Right-click the Default Company folder, and then select Check In.

18. Right-click the IBM Tivoli CCMDB (BUSINESS) folder, and then select Validate.

19. Right-click the folder again, and then select Check In.

20. In the Create Script Package dialog box, click Create.

21. In the Check In dialog box, click Close.

Example:
The following is an example of an enhanced segment of code:

Before:

if ($sessionTimeout)

$reportedFailure = @session::reportFailure($notId, "SESSION_TIMEOUT")

@sessionTimeoutMessage = @initiatingEvent::createExternalServiceMessage()
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$sessionTimeoutMessage.message = "Callout to " & $targetName & " ended due to exceeding the max

session timeout (SESSION_TIMEOUT)."

@sessionTimeoutMessage::send()

endif

After:

if ($sessionTimeout)

$reportedFailure = @session::reportFailure($notId, "SESSION_TIMEOUT")

@sessionTimeoutMessage = @initiatingEvent::createExternalServiceMessage()

$sessionTimeoutMessage.message = "Callout to " & $targetName & " ended due to exceeding the max

session timeout (SESSION_TIMEOUT)."

$sessionTimeoutMessage.additionalTokens = @esmTokens::getSerializedEntrySet()

@sessionTimeoutMessage::send()

endif

2.4.2 Configuring the Event Domain
By default this integration is set up to use an Event Domain of “tivoli-ccmdb”; it is strongly recommended that you use this

default Event Domain. For the integration to be successful, the Event Domain name must match the Client ID of the

integration agent.

The xMatters web server must be running to perform this portion of the integration.

To define an Event Domain:

1. Sign on to xMatters as a Company Administrator, and click the Developer tab.

2. In the Developer menu on the left side of the screen, click Event Domains.

3. On the Event Domains page, click Add New.

4. Enter the following information into the form:

l Name: tivoli-ccmdb

l Description: Tivoli CCMDB Integration

l Script Package: IBM Tivoli CCMDB

5. Click Save.

Defining an Integration Service
For the installation to be successful, the integration service name must match the service specified in the tivoli-ccmdb.xml

file installed on the integration agent.

To define an Integration Service:

1. In xMatters, on the Event Domains page, click the tivoli-ccmdb Event Domain.

2. On the Event Domain Details page, in the Integration Services area, click Add New.

3. Enter the following information into the form:

l Name: tivoli-ccmdb

l Description: Tivoli CCMDB Integration Service

4. Click Save.

Defining Event Domain Constants
Company Administrators and Developers can create Event Domain Constants that will be available in scripting for all event

objects associated with an Event Domain.This integration uses Event Domain Constants to define custom values for the

integration script package.

The integration script package uses the names of the constants defined in the table below to look up the values; it is strongly

recommended that you use the names specified.
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Note: The values for the alarmpointurl and bespushurl constants should be modified to specify the address of the xMatters

web server (to enable the HMTL response options) and the BES device server.

To add an Event Domain Constant:

1. In xMatters, click the Developer tab, and then, in the menu on the left side of the screen, click Event Domain

Constants.

2. In the Event Domain drop-down list, select tivoli-ccmdb.

3. On the Event Domain Constants page, click Add New.

4. Define a Constant Name, Value, and Description for the new constant, according to the table below.

5. Click Save.

6. Repeat the above steps for each of the constants you want to add.

l Note that if the constants are not defined in the web user interface, the scripts will use the values listed in the

Default Values column of the following table.

Note: Shaded rows indicate mandatory settings that are specific to your deployment. You must change the default settings

to match your instance.

Constant Name Default Value Description

xmattersurl http://localhost:8888 Used to specify the address of the xMatters web server. The links

provided in notification content use the alarmpointurl constant

value to locate the xMatters web server which would process the

response. For these links to work, this address must be reachable

from the Device where the User will receive the notification;

normally, this is the IP address or fully-qualified host name of

the xMatters web server.

Populates the $main.alarmpoint_url variable.

bespushurl http://localhost:8888/static Used to specify the address of the BES device server. Populates

the $main.bes_pushurl parameter.

forcefyi disable Force notifications to be informational only (FYI), rather than

requiring responses; this overrides the fyi behaviour specified on

the injected event. Possible values:

l disable: Nothing is forced.

l on: Notifications are forced to be FYI.

l off: Notifications are forced not to be FYI.

Populates the force_fyi parameter.

failsafegroup Tivoli CCMDB FailSafe The fail-safe recipient to notify, typically a group.

The fail-safe group identifies the recipient that will be notified if

an event is injected to xMatters (alarmpoint) engine and no

subscriptions exist that match the event. Set this constant if you

want to change the failsafe group from Tivoli CCMDB FailSafe

to another group defined in xMatters.
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Constant Name Default Value Description

failsafe enabled Controls fail-safe functionality, notifying the fail-safe recipient

via EMAIL under certain circumstances; possible values are:

l enabled: Notify if no subscriptions match or no notifiable

recipients.

l for-subscriptions: Notify if subscription functionality is

enabled AND no subscriptions match.

l for-recipients: Notify if no notifiable recipients.

l disabled: Disable fail-safe functionality.

Populates the $fail_safe parameter.

overridetimeframes false Override Recipients Device Timeframes.

Populates the $override_timeframes parameter.

useemergencydevices false Force the use of emergency Devices.

Populates the $use_emergency_devices parameter.

trackdelivery true Track when each device is delivered to. Setting this to false may

give a performance advantage, but you lose any information

about whether a delivery was successful or not.

Populates the $track_delivery parameter.

annotatedelivery true Enables delivery information annotations back to the

management system. Set this to false to prevent messages about

Device delivery from being submitted to the management

system.

Populates the $main.annotate_delivery parameter.

annotate true Enables submission of annotations back to the management

system.

Populates the $main.annotate parameter.

subscriptionannotate true Enables submission of Subscription annotations back to the

management system.

Populates the $main.subscription_annotate parameter.

tracksubscriptiondelivery true Track when each device is delivered to for Subscriptions.

Populates the $track_subscriptionDelivery parameter.

timeout 259200 Amount of time (in seconds) the event is allowed to run before

timing out. 259200 seconds = 72 hours.

Populates the $main.timeout parameter.

maxinvalidresponses 3 Specifies the maximum number of invalid responses allowed

before notification is no longer requeued.

Populates the $main.maxInvalidResponses parameter.

enablehtmlemail true Enables HTML email functionality.

Populates the $main.enable_HTML_Email parameter.
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Constant Name Default Value Description

uselogo true Set this if you want the logo displayed within HTML email

notifications.

Populates the $main.use_logo parameter.

debug false Indicates whether to use the debug level for logging messages.

Populates the $main.debug variable.

2.4.3 Adding the Web Service User
This integration requires a Web Service User for the Tivoli data synchronization process., and to modify the default

integration agent web services user to have access to the Query Incident web service call.

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip this section.

To set up a Web Service User:

1. In xMatters, click the Users tab, and then click Add Web Service User.

2. Enter the following information into the form:

l User ID: APWSU

l Description: xMatters Web Service User

l Password: type the User’s password (default is password)

l Verify Password: retype the password to verify it.

3. Set this User to have access to all of the available web services.

4. Click Save.

5. Click Find Web Services Users, and then click All.

6. In the returned search results, click IA_User.

7. On the Details for IA_User page, confirm that the list of Allowed Web Services includes the Query Incident web

service; if it is not listed in the Allowed Web Services list, select it in the Denied Web Services list, and then click

Add.

8. Click Save.

Note: To ensure that you do not compromise your security, do not use the default password on production systems.

2.4.4 Configuring a Supervisor
The Data Synchronization component requires a supervisor for new Users, Teams, and Groups. This supervisor must be an

active User assigned to the Person Supervisor and Group Supervisor Roles. If you have already installed the IBM Tivoli

Service Request Manager integration, you can skip this section.

Note: If you are using xMatters lite, you are limited to a single Administrator, and must change the Data Synchronization

configuration files to refer to the default Company Administrator.

To configure a separate Tivoli administrator:

1. In the web user interface, click the Users tab.

2. In the Users menu on the left side of the screen, click Add User.

3. On the Add a User page, enter the following information into the form (this will ensure that the User details match the

default settings in the Data Synchronization configuration files):
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l User ID: tivoliadmin

l First Name: Tivoli

l Last Name: Admin

4. In the Available Roles list, select Standard User, Person Supervisor, and Group Supervisor, and then click Add.

(Press Ctrl to select more than one Role in the list.)

5. Click Save.

6. On the Change Web Login page, type a password for the Tivoli admin in the New Password field, and then re-type it

in the Verify New Password field.

7. Click Save to create the User.

For more information about these tasks, refer to the xMatters (alarmpoint) engine user guide.

2.4.5 Configuring a Subscription
With Subscriptions, xMatters can automatically notify Users whenever an event matches a pre-defined set of criteria. For

example, when a certain type of error occurs on a specific asset or service, xMatters can notify a particular Group.

The following sections describe how to manage Subscriptions in xMatters, including instructions on how to configure a

Subscription panel and assign Subscriptions to Users. Note that this feature is strictly optional; the ability to directly target

Users, Devices, and Groups through integration or web messaging is sufficient for most deployments.

To allow Users to subscribe to specific criteria on injected events, you must configure a Subscription panel, which requires

the following steps:

n Define the Event Domain predicates

n Define a Subscription Domain

n Create a Subscription

n Create a Fail-Safe Group

Defining Event Domain predicates
The default integration configuration uses the following Event Domain predicates to which you can subscribe:

l CHANGECATEGORY

l CHANGETYPE

l IMPACT

l RISK

l URGENCY

l PRIORITY

l FAILUREPROBABILITY

l AFFECTED_CI_NAME

Note: You can also use the following steps to add other predicates that you consider important and which you plan to

add to the integration.

To define the Event Domain predicates:

1. In xMatters, click the Developer tab.

2. On the Event Domains page, click tivoli-ccmdb.

3. On the Event Domain Details page, click Add New.

4. Add the following predicates to the Event Domain:
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Predicate Type Important Description

CHANGECATEGORY List Yes A list of change categories available within the Tivoli System.; default

values to add are:

l Major

l Minor

l Significant

CHANGETYPE List A list of change types available within the Tivoli System.; default

values to add are:

l Emergency

l Normal

l Standard

IMPACT List Yes A list of possible impacts; default values to add are:

l Critical

l High

l Medium

l Low

l Planning

RISK List Yes A list of possible risk levels assigned to workflow assignments; default

values to add are:

l Critical

l High

l Medium

l Low

l None

URGENCY List The urgency of the workflow assignment; default values to add are:

l Critical

l High

l Medium

l Low

l Planning

PRIORITY List A list of possible priorities assigned to the workflow assignment;

default values to add are:

l Immediate

l High

l Medium

l Low

l Planning

Event Domain predicates
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Predicate Type Important Description

FAILUREPROBABILITY List A list of possible failure probabilities assigned to the workflow

assignment; default values to add are:

l High

l Medium

l Low

AFFECTED_CI_NAME Text The name of the affected Configuration Item to which the workflow

assignment is related.

Note: When specifying a list-type predicate, populate the list with any values you want to subscribe against. For best

results, match the predicate value lists with the incident parameter value lists. If preferred, the predicate type can

be changed to Text. This allows Users to specify matching criteria based on text constraints (e.g. CONTAINS, ENDS

WITH, STARTS WITH and MATCHES), rather than a value list selection.

5. Click Save.

Defining a Subscription Domain
The Subscription Domain is the reference point of the Subscription panel and allows you to control who can create

Subscriptions, how recipients can respond to Subscription notifications, and which Event Domain predicates can be used to

create a Subscription. You must create a Subscription Domain before you can create Subscriptions with the new panel.

To create a Subscription Domain:

1. On the Developer tab, in the Developer menu, click Add Subscription Domain.

2. In the Event Domain drop-down list, select tivoli-ccmdb, and then click Continue.

3. On the Subscription Domain Details page, in the Name field, type Tivoli_CCMDB.

4. Select the One-Way check box.

5. In the Type of Management drop-down list, select Both.

6. Click Continue.

7. On the Select Appropriate Predicates page, add all of the predicates to the Applied Predicates list, and then click

Continue.

8. On the Select Roles page, specify the Roles you want to be able to create Subscriptions on the Domain, and then click

Save.

Note: For more information about working with Event and Subscription Domains, see the xMatters (alarmpoint) engine

installation and administration guide.

Creating a Subscription
You can now subscribe to Tivoli events that match specific criteria. For example, you could configure a subscription that

would send an informational notification to a specific User each time an event entered the system that was of critical severity.

These notifications, and their responses, do not affect the normal progression of an event through the system.

To create a Subscription:

1. On the Alerts tab, in the Alerts menu, click My Subscribed Alerts.

2. Select the Tivoli_CCMDB Subscription Domain, and click the Add New link.
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3. On the Subscription Details page, specify a name for the Subscription, and set the Subscription criteria.

4. When you are satisfied with the criteria, click Save to create the Subscription.

2.5 Filtering and suppression
The xMatters integration agent's Portable Filtering and Suppression Module is a built-in module that maintains a rolling

record of previously injected events, and allows for the suppression of duplicates (also referred to as "deduplication"). This

helps avoid disruption of traffic due to inadvertent loads that can result when, for example, improperly configured

management systems inject duplicated events.

To install the module:

1. Copy the xM-IBM-Tivoli-CCMDB\components\alarmpoint-integration-agent\dedeuplicator-filter.xml file

from the extracted integration archive into the <IAHOME>\conf folder.

Unix-specific changes
If you are installing this integration on a Unix deployment, you must add the following parameter to the

<IAHOME>\conf\wrapper.conf file; this will add a system property to the JVM:

wrapper.java.additional.<n>=-Ddeduplicator.file=conf/deduplicator-filter.xml

Change the <n> number to be the actual consecutive number, depending on the number of additional parameters above the

new parameter.

2.5.1 Configuration
To configure the module, add your required filters to the deduplicator-filter.xml file (located at <IAHOME>/conf/).You

can add any number of filters, each of which must consist of the following filter attributes; the "Default Value" column

identifies the out-of-the-box settings for the integration:

Attribute Description Default Value

predicates A list of incoming event tokens (or "predicates") that are considered

relevant for the purpose of correlation.

incident_id

failureprobability

owner

ownergroup

impact

urgency

priority

risk

status

urgency

suppression_period The length of time (in seconds) to suppress duplicate. 1800

window_size The maximum number of unique events to record. 100

Deduplication filter attributes

The default filter for this integration is as follows:

<filter name="tivoliccmdb">

<predicates>

<predicate>incident_id</predicate>

<predicate>failureprobability</predicate>

<predicate>owner</predicate>

<predicate>ownergroup</predicate>
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<predicate>impact</predicate>

<predicate>urgency</predicate>

<predicate>priority</predicate>

<predicate>risk</predicate>

<predicate>status</predicate>

<predicate>urgency</predicate>

</predicates>

<suppression_period>1800</suppression_period>

<window_size>100</window_size>

</filter>

This default filter will suppress any notification within a 30-minute timeframe that has identical values for incident_id,

failureprobability, owner, ownergroup, impact, urgency, priority, risk, status, and urgency as an existing notification. All

duplicate events are logged in the log file with a warning message: **Deduplicator Suppressed Notification**.

This module is implemented to prevent minor changes to the change record being injected into xMatters, which can result in

multiple event notifications for subscribing Users.

2.6 Configuring Synchronization
This section describes the default behavior of the user and group synchronization included with this integration. Please read

through this section and update the default configuration to match your requirements.

Note: If you have already installed the IBM Tivoli Service Request Manager integration, you can skip this section.

2.6.1 Default Behavior
The following definitions are used for the terminology in the table below:

n Include/Exclude: Identifies whether the object is included or excluded when being synchronized with AlarmPoint.

n Seed only: If true, the object will be created in xMatters but will not be updated; otherwise, all updates will be

synchronized with xMatters.

n Deletable: If false, when the object is deleted in Tivoli, it will not be deleted from xMatters; otherwise, when the

object is deleted from Tivoli, it will also be deleted from xMatters.

The default behavior for each synchronized object is as follows:

Object Include/Exclude Seed only Deletable

User Include false true

Email Device Include false true

Voice Device Include false true

SMS Device Include false true

Group Include false true

Team Include false

Coverage Include false

Note: The behavior for Users and Groups is controlled by PersonSyncRules.xsl and GroupSyncRules.xsl, respectively.
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2.6.2 Configuration
All configuration for User and Group synchronization is contained in the XSL stylesheets that were copied to the

C:\xmatters\tivoli\conf directory on the WebSphere server (as described in "Installing the WebSphere files" on page 6).

These stylesheets allow you to define the synchronization behavior for all synchronized objects as well as defining the values

for each field of the xMatters object.

The XML document transformed using this stylesheet is defined by the Object Structure within Tivoli; the resulting

document must be in the format accepted by the xMatters web services. If the resulting document contains no content or a

single element with a value, that object will be excluded and either a generic message or the value of the single element will

be logged.

This section provides an example of how to update the Person.xsl file so that Users with the job title of “supervisor” will

be assigned to the Person Supervisor role.

To update the Person.xsl file:

1. Open the C:\xmatters\tivoli\conf\Person.xsl file on the WebSphere server, and locate the following section of

code:

<ap:roles>

<ap:role>

<ap:name>Standard User</ap:name>

</ap:role>

</ap:roles>

2. Update the section to resemble the following:

<ap:roles>

<ap:role>

<ap:name>Standard User</ap:name>

</ap:role>

<xsl:if test="mx:TITLE = 'supervisor'">

<ap:role>

<ap:name>Person Supervisor</ap:name>

</ap:role>

</xsl:if>

</ap:roles>

3. Save and close the file.

Note: These effects will only take action on all subsequent user updates. For the changes to take effect on all Users

immediately, you must run the initial synchronization tool to synchronize all changes to xMatters.

2.6.3 Configuring User Service Providers
By default, Devices created or updated via Data Synchronization are set to use the xdxMatters Virtual Device providers. To

change the User Service Providers for Devices in Data Synchronization, edit the XSL files for the Devices you are adding

(i.e., PhoneDevice.xsl, EmailDevice.xsl, and SMSDevice.xsl), and add the following section:

<ap:userServiceProvider>

<ap:name>SMTP Email</ap:name>

</ap:userServiceProvider>

Replace "SMTP Email" with the name of the User Service Provider you want the Device to use.

For more information, XML and XSL references are available on the w3schools web site at http://www.w3schools.com/.
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Chapter 3: Integration Validation
After configuring xMatters and Tivoli, you can validate that communication is properly configured. It is recommended that

you start the components in the following order:

n IBM Tivoli Change and Configuration Management Database

n xMatters Application and Notification Server Nodes

n xMatters integration agent

Consult the respective user manuals for details on starting these applications.

The following sections will test the combination of xMatters and Tivoli for notification delivery and response, Subscription

Panel functionality, and synchronization configuration.

3.1 Testing Initial Synchronization
The initial synchronization tool is designed to force a push of all user and group information from the Tivoli server to the

xMatters server. This is useful if you want to initially create all Tivoli users and groups in xMatters. Note that if you have

already installed the IBM Tivoli Service Request Manager integration, you can skip this section as the synchronization

feature is shared between both Tivoli integrations.

You can also use the initial synchronization to update all Tivoli users and groups in xMatters to either propagate

configuration changes or re-attempt previous failed synchronizations.

Note: The initial synchronization program requires a Java JRE, version 1.5 or greater.

To run the initial synchronization program:

1. On the WebSphere server, navigate to the \xmatters\tivoli directory.

2. Open the runInitialSync.bat file and update the path to the Java executable.

3. Save and close the file.

4. Run runInitialSync.bat.

Note: If you want to run the initial synchronization from a location other than the WebSphere server, ensure that you use

the same configuration files as those on the WebSphere server.

3.2 Triggering a notification
When a change record is routed to the next stage in the workflow, a notification will be sent into xMatters provided the

following configuration is in place:

l There is a workflow assignment task in the workflow process.

l There is at least one assignment in the task that uses a valid communication template and the Send E-mail option is

selected.

l The selected role contains users/groups that exist in xMatters and do NOT point to email addresses within Tivoli.

l The selected communication template for the assignment has the Use xMatters option selected.

When Tivoli sends a notification, if the communication template is set to use xMatters, the notification is sent to the

integration agent.

If the notification is a workflow assignment notification (as opposed to a general communication), the data will be enriched

with the related change information before being passed into xMatters where the recipient and subscribed Users are

determined and notified.
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3.3 Responding to a notification
This section describes how to respond to a notification from xMatters. In the following example, the notification is received

on an Email Device, but the process is similar for all Devices.

To respond to a notification:

1. When a notification arrives for the User, the Device indicates the number of calls received.

2. Opening the notification displays its details:

3. Scrolling down will display the remainder of the details, and the list of possible replies:
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4. To respond to the notification, the User clicks a response choice, and xMatters updates the event in Tivoli.

3.4 Viewing response results
When an action is taken on a notification, the assignment memo field is updated with the response and responder details.

Delivery information is written to the WorkLog on the change record.

n Updated workflow assignment (note the status change to ASSESS):



xMatters (alarmpoint) for IBM Tivoli Change and Configuration Management Database

Chapter 3: Integration Validation | 35

n Updated the workflow assignmentmemo field with details of the response:

l Updated the change record's Work Log with Device delivery information:
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3.5 Testing the Subscription Panel
To test Subscriptions, ensure that you have created a Subscription (for more information, see "Creating a Subscription" on

page 28). Trigger a notification that matches the criteria that you have configured your Subscription to match. You will

receive an FYI Notification (informational only) which will not have any response choices available.
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Chapter 4: Optimizing and Extending the Integration
This section describes some of the available methods you can use to optimize or extend the xMatters (alarmpoint) for IBM

Tivoli Change and Configuration Management Database integration.

4.1 Response choices
The integration allows recipients to respond to notifications with several default choices, some of which are injected back to

the Tivoli server, updating the original workflow assignment. Users notified on email Devices also have the ability to

respond with an extra annotation message which will be logged in the original workflow assignment.

Note: It is possible to define multiple instructions in a workflow task. For this integration, the inbound process will ONLY

provide ACCEPT, REJECT or REASSIGN options. This means that the integration is expecting no more than TWO

instructions, one positive and, optionally, one negative).

More than two instructions will not be supported by the integration.

The following is a list of the default response choices available with the integration and their associated actions on the

xMatters event and the Tivoli workflow assignment.

Response xMatters Action Tivoli Update Availability

Accept Delinks all Users from the event, not

allowing them to submit responses.

Mark the workflow assignment as

complete for the current user and

updates the memo field on the

workflow task.. This may cause the

workflow task to complete

depending on whether the

workflow is configured as "When

ANY assignment is accepted" OR

"When ALL assignments are

accepted" within Tivoli.

All non-FYI devices

Reject Delinks all Users from the event, not

allowing them to submit responses.

Updates the workflow assignment

to complete and rejects the change

order. Updates the memo field on

the workflow task.This response

will ONLY be available if the

current task is defined with a

negative response option. This is

configurable within Tivoli.

All non-FYI devices

Reassign Delinks the responder from the event. Updates the workflow assignment

to FORWARDED and creates a

new workflow assignment for the

user to whom the task was

reassigned. Updates the memo field

and marks the current assignment as

reassigned.

This functionality is

available for Email Devices

only.

Annotate Halts delivery of notifications to any

other Devices the responding User

may have configured.

Any additional notes added to the

response are recorded on the

workflow assignment’s Work Log.

This functionality is

available for Email Devices

only.

Default response choices
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4.1.1 Adding annotation messages
Two-way email Device notifications (not FYI) can add extra annotations that will be added to the workflow assignment as a

message on the workflow assignmentt's Work Log. To add an extra annotation, respond to an email notification with the

following format in the subject line:

RESPONSE <Choice> <Message>

<Choice> can be any of the response choices listed in the table above, and <Message> can be any content you want to add

as the annotation.

4.1.2 Reassigning workflow assignments
Two-way email Device notifications (not FYI) can reassign a workflow task to another user. To reassign the task, respond to

an email notification with the following format in the subject line:

RESPONSE REASSIGN <User>

<User> must be a valid user in the Tivoli system.

4.2 Delivery Annotations
This integration extensively annotates the originating workflow assignment, but this may not be desirable in all

environments. To prevent workflow assignment delivery annotations, change the "annotate" Event Domain Constant to false.

For more information, see "Defining Event Domain Constants" on page 22.

4.3 Altering the duration of events
You can modify the amount of time xMatters will send out notifications for a particular event before it times out by changing

the "timeout" Event Domain Constant, which stores the number of seconds the notifications will be allowed to continue

before timing out.

The default value is 259200, which is the number of seconds in a 72-hour period. You can change the delay to a two-hour

timeout by changing the value of the constant to 7200.

For more information, see "Defining Event Domain Constants" on page 22.

4.4 FYI Notifications
You can make all notifications informational only (i.e., the user is not offered any response choices) by setting the "forcefyi"

 Event Domain Constant to "on". This makes all normal and Subscription notifications one-way (FYI). For more information,

see "Defining Event Domain Constants" on page 22.

Note: All FYI events are set to priority LOW; this allows users to prevent the alerts from being sent to specific Devices by

configuring their Devices to be used for only Medium and High priority alerts.

4.5 Constructing BES and email notifications
You can configure xMatters to create BES and HTML email notifications.

Note: Some email clients, such as Microsoft Outlook 2007, may not display HTML elements correctly. It is recommended

that you test the HTML compatibility of your email client before implementing the HTML email feature.
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To enable BES and/or HTML email:

1. In xMatters, click the Developer tab, and then, in the menu on the left side of the screen, click Event Domain

Constants.

2. In the Event Domain drop-down list, select .tivoli-ccmdb.

3. On the Event Domain Constants page, do the following:

l Set the enablehtmlemail constant to true.

l Set the uselogo constant to true (if you want your HTML email to show a logo).

l Set the alarmpointurl constant to the base URL of your xMatters web server. (default is localhost).

l If you are using BES, set the bespushurl constant to the URL of the BES server.

Note: If the Event Domain Constants are not present, you can add them using the names specified above. For more

information, see "Defining Event Domain Constants" on page 22.

4.6 Uninstalling
For instructions on removing an xMatters deployment, refer to the xMatters (alarmpoint) engine installation and

administration guide.
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Chapter 5: Configuration Variable Reference
This section outlines and describes the configuration variables available in the initial PROCESS Action Script.

5.1 Global configuration variables
These variables are available throughout the script package, and are parameters of the “main” object. The value assigned to

each variable is its default value within the script.

Note that many of the configuration variables are configurable using the Event Domain Constants described in "Defining

Event Domain Constants" on page 22. Those variables are not listed here.

Variable Description

$main.use_logFile = false Specify whether to use an alternate log file for debugging

messages. This variable is ignored unless $main.debug is also set to

true.

$main.logFile = "../logs/" Defines the file used to log debugging information (only if

$main.use_logfile is set to true).

$main.HTML_form_url = $AlarmPoint_URL &

"/jsp/ProcessNotificationResponse.jsp"

Specifies the URL of the xMatters web server’s Process

Notification Response JSP form, used by HTML email and BES to

inject responses through the system.

$main.logo = $AlarmPoint_URL &

"/static/images/logos/alarmpoint/UNKNOWN.png"

Specifies the path to the graphic displayed on HTML (email and

BES) notifications.

$main.logo_alt_text = “[If the logo does not appear

you may be blocking images or you may be outside

a firewall. If the latter, the links will not work for

responding and you should respond by replying to

this email as described below.]”

The alternate text to display if the HTML email logo is

unavailable.

Note: If the logo does not display, it is unlikely that the HTML_

form_url is valid and responses will not be injected from HTML

Devices (email and BES).

$main.numeric_pager_number = “555-1212” The phone number to display for calling in to retrieve event

information. This variable has a non-existent number as a default

value; a real call-in number must be supplied, or a message

indicating that an xMatters event has occurred.

Gobal variables

5.2 Local configuration variables
These variables are available only in this script, and control how the script runs. For more information about the initial

PROCESS script, consult the xMatters Online Developer's Guide.

5.2.1 FYI Notification Variables
The following variables configure the behavior of informational-only, or FYI, notifications. The value assigned to each

variable is the default value within the script.

Note: For more information on the behavior associated with informational-only notifications, see "FYI Notifications" on

page 38.
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Variable Description

$use_email_for_fyi = true

$use_phone_for_fyi = false

$use_im_for_fyi = true

$use_text_phone_for_fyi = true

$use_text_pager_for_fyi = true

$use_numeric_pager_for_fyi = true

$use_bes_for_fyi = true

$use_generic_for_fyi = true

Configure Device filters for informational-only (FYI) notifications.

Setting these flags to false prevents that Device type from being notified with

informational (FYI) messages.

FYI variables
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